Opened 6 years ago

Closed 6 years ago

#583 closed defect (worksforme)

/bin/sh: 28: cannot create .../.openssl/ssl/man/man3/hmac.3: Too many levels of symbolic links

Reported by: Gene Aumson Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.7.x
Keywords: openssl install Cc:
uname -a: Linux vagrant-ubuntu-trusty-32 3.13.0-29-generic #53-Ubuntu SMP Wed Jun 4 21:02:19 UTC 2014 i686 i686 i686 GNU/Linux
nginx -V: nginx version: nginx/1.7.1
built by gcc 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
TLS SNI support enabled
configure arguments: --with-debug --prefix=../installed --with-pcre=../pcre-8.35 --with-zlib=../zlib-1.2.8 --with-openssl=../openssl-1.0.1h --with-http_gzip_static_module --with-http_addition_module --with-http_stub_status_module --with-http_ssl_module --with-http_realip_module --with-http_perl_module --with-http_geoip_module --add-module=../ngx_http_substitutions_filter_module --add-module=../nginx-eval-module --add-module=../nginx_http_recaptcha_module --add-module=../nginx_secure_cookie_module --add-module=../ngx_http_redis-0.3.7

Description

I'm building nginx-1.7.1, with the configure argument --with-openssl=../openssl-1.0.1h.

If I run the build once, with a fresh extract of the OpenSSL sources, everything works fine.

However, if I run make a subsequent time, using that same leftover ../openssl-1.0.1h folder, I get the following error:

installing man3/hmac.3
/bin/sh: 28: cannot create /vagrant/nginx-distil/nginx-1.7.1/../openssl-1.0.1h/.openssl/ssl/man/man3/hmac.3: Too many levels of symbolic links
make[2]: *** [install_docs] Error 2
make[2]: Leaving directory `/vagrant/nginx-distil/openssl-1.0.1h'
make[1]: *** [../openssl-1.0.1h/.openssl/include/openssl/ssl.h] Error 2
make[1]: Leaving directory `/vagrant/nginx-distil/nginx-1.7.1'
make: *** [build] Error 2

A workaround is to delete the folder ../openssl-1.0.1h/.openssl, at which point make in nginx-1.7.1 works as expected.

Change History (1)

comment:1 by Maxim Dounin, 6 years ago

Resolution: worksforme
Status: newclosed

Works fine here. The error message suggests there is a symlink loop somewhere on the way, but it's not something observed with hmac.3 in openssl-1.0.1h.

I would recommend to check that the problem appears when using normal filesystem (the /vagrant/ part in the path suggests it's not). If it is, start digging into OpenSSL sources to find out what happens. It's highly unlikely the problem is in nginx, as it more or less just calls the config --prefix=... && make && make install within OpenSSL source directory.

Note: See TracTickets for help on using tickets.