Opened 6 years ago

Closed 6 years ago

#587 closed defect (duplicate)

src/core/ngx_crypt.c:82:5: error: 'MD5_Init' is deprecated: first deprecated in OS X 10.7

Reported by: Gene Aumson Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.6.x
Keywords: Cc: Apple, LLVM, version, 5.1, (clang-503.0.40), (based, on, 3.4svn)
uname -a: Darwin Fs-MacBook-Pro.local 13.2.0 Darwin Kernel Version 13.2.0: Thu Apr 17 23:03:13 PDT 2014; root:xnu-2422.100.13~1/RELEASE_X86_64 x86_64
nginx -V: nginx version: nginx/1.6.0
built by clang 5.1 (clang-503.0.40) (based on LLVM 3.4svn)
TLS SNI support enabled
configure arguments: --with-debug --prefix=../installed --with-cc-opt=-Wno-deprecated-declarations --with-http_gzip_static_module --with-http_addition_module --with-http_stub_status_module --with-http_ssl_module --with-http_realip_module --with-http_perl_module --with-http_geoip_module --add-module=../ngx_http_substitutions_filter_module --add-module=../nginx-eval-module --add-module=../nginx_http_recaptcha_module --add-module=../nginx_secure_cookie_module --add-module=../ngx_http_redis-0.3.7

Description

cc -c -pipe  -O -Wall -Wextra -Wpointer-arith -Wconditional-uninitialized -Wno-unused-parameter -Werror -g  -I src/core -I src/event -I src/event/modules -I src/os/unix -I objs \
		-o objs/src/core/ngx_crypt.o \
		src/core/ngx_crypt.c
src/core/ngx_crypt.c:82:5: error: 'MD5_Init' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
    ngx_md5_init(&md5);
    ^
src/core/ngx_md5.h:30:25: note: expanded from macro 'ngx_md5_init'
#define ngx_md5_init    MD5_Init
                        ^
/usr/include/openssl/md5.h:113:5: note: 'MD5_Init' declared here
int MD5_Init(MD5_CTX *c) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:83:5: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
    ngx_md5_update(&md5, key, keylen);
    ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:84:5: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
    ngx_md5_update(&md5, (u_char *) "$apr1$", sizeof("$apr1$") - 1);
    ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:85:5: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
    ngx_md5_update(&md5, salt, saltlen);
    ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:87:5: error: 'MD5_Init' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
    ngx_md5_init(&ctx1);
    ^
src/core/ngx_md5.h:30:25: note: expanded from macro 'ngx_md5_init'
#define ngx_md5_init    MD5_Init
                        ^
/usr/include/openssl/md5.h:113:5: note: 'MD5_Init' declared here
int MD5_Init(MD5_CTX *c) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:88:5: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
    ngx_md5_update(&ctx1, key, keylen);
    ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:89:5: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
    ngx_md5_update(&ctx1, salt, saltlen);
    ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:90:5: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
    ngx_md5_update(&ctx1, key, keylen);
    ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:91:5: error: 'MD5_Final' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
    ngx_md5_final(final, &ctx1);
    ^
src/core/ngx_md5.h:32:25: note: expanded from macro 'ngx_md5_final'
#define ngx_md5_final   MD5_Final
                        ^
/usr/include/openssl/md5.h:115:5: note: 'MD5_Final' declared here
int MD5_Final(unsigned char *md, MD5_CTX *c) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:94:9: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
        ngx_md5_update(&md5, final, n > 16 ? 16 : n);
        ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:101:13: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
            ngx_md5_update(&md5, final, 1);
            ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:104:13: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
            ngx_md5_update(&md5, key, 1);
            ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:108:5: error: 'MD5_Final' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
    ngx_md5_final(final, &md5);
    ^
src/core/ngx_md5.h:32:25: note: expanded from macro 'ngx_md5_final'
#define ngx_md5_final   MD5_Final
                        ^
/usr/include/openssl/md5.h:115:5: note: 'MD5_Final' declared here
int MD5_Final(unsigned char *md, MD5_CTX *c) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:111:9: error: 'MD5_Init' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
        ngx_md5_init(&ctx1);
        ^
src/core/ngx_md5.h:30:25: note: expanded from macro 'ngx_md5_init'
#define ngx_md5_init    MD5_Init
                        ^
/usr/include/openssl/md5.h:113:5: note: 'MD5_Init' declared here
int MD5_Init(MD5_CTX *c) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:114:13: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
            ngx_md5_update(&ctx1, key, keylen);
            ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:117:13: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
            ngx_md5_update(&ctx1, final, 16);
            ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:121:13: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
            ngx_md5_update(&ctx1, salt, saltlen);
            ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:125:13: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
            ngx_md5_update(&ctx1, key, keylen);
            ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
src/core/ngx_crypt.c:129:13: error: 'MD5_Update' is deprecated: first deprecated in OS X 10.7
      [-Werror,-Wdeprecated-declarations]
            ngx_md5_update(&ctx1, final, 16);
            ^
src/core/ngx_md5.h:31:25: note: expanded from macro 'ngx_md5_update'
#define ngx_md5_update  MD5_Update
                        ^
/usr/include/openssl/md5.h:114:5: note: 'MD5_Update' declared here
int MD5_Update(MD5_CTX *c, const void *data, size_t len) DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
    ^
fatal error: too many errors emitted, stopping now [-ferror-limit=]
20 errors generated.
make[2]: *** [objs/src/core/ngx_crypt.o] Error 1
make[1]: *** [build] Error 2
make: *** [nginx-1.6.0/objs/nginx] Error 2

Error can be avoided by using the CC option -Wno-deprecated-declarations.

Change History (1)

comment:1 by Valentin V. Bartenev, 6 years ago

Resolution: duplicate
Status: newclosed

A duplicate of #584.

Note: See TracTickets for help on using tickets.