Opened 5 years ago

Closed 5 years ago

#589 closed defect (duplicate)

url rewrite encoding issue

Reported by: rajacheran@… Owned by:
Priority: blocker Milestone:
Component: nginx-core Version: 1.7.x
Keywords: Cc:
uname -a: Linux creator-ubuntu-64-1 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.1.19

Description

Currently we are using apache mod_rewrite for url rewrite. We want to remove apache and move the url rewrite to our Load Balancer(which is nginx server).

The rewrite rule

rewrite ^/form-embed/(.*) /formembed.do?$1 break;

rewrites the url /form-embed/a=1&b=2&c=3 as /formembed.do?a=1&b=2&c=3 (same behaviour as apache). But when the url contains <SPACE> the query string appended is getting encoded, even '&' is getting encoded as '%26'

the rul /form-embed/a=1&b=2&c=Times New Roman gets rewritten as /formembed.do?a=1%26b%3D2%26c%3DTimes+New+Roman but for the same case apache(version 1.3) correctly rewrites as a=1&b=2&c=Times+New+Roman.

Is it intended behaviour or its a bug? Please suggest us solution to solve this problem, we need to solve this problem ASAP.

Change History (1)

comment:1 Changed 5 years ago by mdounin

  • Resolution set to duplicate
  • Status changed from new to closed

Looks like the same problem as in #408.

Note: See TracTickets for help on using tickets.