Opened 6 years ago

Closed 6 years ago

#591 closed defect (fixed)

Windows nginx-1.7.3 build does not start

Reported by: Ilyas Bakirov Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.7.x
Keywords: Cc:
uname -a: Checked on this platforms: Windows XP SP2, Windows Server 2003 R2 SP2 Enterprise x64, Windows 8.1 x64
nginx -V: 1.7.3

Description

1.7.3 does not start and gives error:

The specified executable is not a valid Win32 application.

Prior versions and 1.7.2 starts without errors on Windows OS. I think 1.7.3 windows build broken

Change History (2)

comment:1 by Maxim Dounin, 6 years ago

The 1.7.3 Windows binaries were compiled using MSVC 2013 (previously, binaries were compiled using MSVC 2010), and likely this is the cause (it works fine here under Windows 7 though). I'll take a look.

comment:2 by Maxim Dounin, 6 years ago

Resolution: fixed
Status: newclosed

The binary is indeed fails to load on Windows XP (though runs fine on Windows 8.1). The problem is that MSVC 2013 (and 2012) builds Vista+ binaries by default. While it is possible to build XP-compatible binaries using MSVC 2013, the process looks cumbersome, so I've reverted back to MSVC 2010.

I've replaced nginx/Windows 1.7.3 binary with one built with MSVC 2010, it now works fine on XP and other old systems.

Note: See TracTickets for help on using tickets.