Opened 8 years ago

Closed 8 years ago

#6 closed defect (invalid)

limit_req_log_level directive not honoured

Reported by: openid-provider.appspot.com/theinvincible Owned by: somebody
Priority: minor Milestone:
Component: nginx-module Version: 1.0.x
Keywords: limit_req_log_level HttpLimitReqModule Cc:
uname -a: 2.6.18-238.19.1.el5PAE #1 SMP Fri Jul 15 08:15:44 EDT 2011 i686 athlon i386 GNU/Linux
nginx -V: nginx: nginx version: nginx/1.0.5 nginx: built by gcc 4.1.2 20080704 (Red Hat 4.1.2-50) nginx: TLS SNI support disabled nginx: configure arguments: --user=nginx --group=nginx --prefix=/usr/share/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --http-client-body-temp-path=/var/lib/nginx/tmp/client_body --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --pid-path=/var/run/nginx.pid --lock-path=/var/lock/subsys/nginx --with-debug --with-http_ssl_module --with-http_realip_module --with-http_image_filter_module --with-http_geoip_module --with-http_sub_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_degradation_module --with-http_stub_status_module --without-mail_pop3_module --without-mail_imap_module --without-mail_smtp_module --without-http_uwsgi_module --with-file-aio --with-cc-opt='-O2 -g -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables' --with-cc-opt='-O2 -g -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables'

Description

I've noticed that one of the CMSs on a test server is loading slowly. After turning on debugging, I noticed that this is because of the request limiting:

[warn] 473#0: *553 delaying request, excess: 0.433, by zone "reqrate", client: xx.xx.xx.xx, server: xx.xx.xx.xx, request: "GET /path/to/file HTTP/1.1", host: "xx.xx.xx.xx", referrer: "http://xx.xx.xx.xx/"

It is classified as a warning even if I have "limit_req_log_level error;" in the configuration file.

Change History (1)

comment:1 Changed 8 years ago by mdounin

  • Resolution set to invalid
  • Status changed from new to closed

This is not a bug. Directive "limit_req_log_level" is to set log level for rejecting requests, delaying requests are logged at less severe level.

Note: See TracTickets for help on using tickets.