Opened 6 years ago

Closed 6 years ago

#646 closed defect (worksforme)

can not compile nginx-1.7.6(with epoll supported) with uclibc

Reported by: Xia Xiaojin Owned by:
Priority: major Milestone:
Component: nginx-module Version: 1.7.x
Keywords: epoll Cc: xiaojin2630@…
uname -a: Linux devel 2.6.32-5-686 #1 SMP Sun Sep 23 09:49:36 UTC 2012 i686 GNU/Linux
nginx -V: nginx version: nginx/1.7.6
built by gcc 4.6.1 (Buildroot 2011.11-git)
TLS SNI support enabled
configure arguments: --prefix=/data --sbin-path=/data/local/bin/nginx --conf-path=/data/etc/nginx/nginx.conf --error-log-path=/data/local/log/nginx/error.log --pid-path=/data/local/log/nginx.pid --http-log-path=/data/local/log/nginx/access.log --http-client-body-temp-path=/var/run --http-proxy-temp-path=/var/run --http-fastcgi-temp-path=/var/run --http-uwsgi-temp-path=/var/run --http-scgi-temp-path=/var/run --with-cc=/toolchain/0932-x86-2011-11git/usr/bin/i686-linux-gcc --with-cpp=/toolchain/0932-x86-2011-11git/usr/bin/i686-linux-g++ --user=nobody --with-pcre --with-poll_module --with-select_module --with-ipv6 --with-http_ssl_module --with-http_spdy_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_auth_request_module --with-http_random_index_module --with-http_secure_link_module --with-http_degradation_module --with-http_stub_status_module --with-zlib= --with-openssl=

Description

hi, all:

i want compile nginx 1.7.6 on my uclibc host with epoll supported,
but the configure export "checking epoll .... found but is not working.'

my host:
root [ nginx-1.7.6 ]# uname -sa
Linux devel 2.6.32-5-686 #1 SMP Sun Sep 23 09:49:36 UTC 2012 i686 GNU/Linux

my target:
libuClibc-0.9.32.so
ucf [ /root ]# uname -sa
Linux ucf 3.14.0-rc7 #5 SMP Tue Aug 5 10:15:00 CST 2014 i686 GNU/Linux
ucf [ /root ]# gzip -dc /proc/config.gz |grep -i epoll
CONFIG_EPOLL=y

vim /data/etc/nginx/nginx.conf
events {

use epoll;
worker_connections 1024;

}
buti will run it :
ucf [ /root ]# /data/etc/init.d/nginx start

Starting nignx: nginx: [emerg] invalid event type "epoll" in /data/etc/nginx/nginx.conf:13

done

ucf [ /root ]# nginx -V
nginx version: nginx/1.7.6
built by gcc 4.6.1 (Buildroot 2011.11-git)
TLS SNI support enabled
configure arguments: --prefix=/data --sbin-path=/data/local/bin/nginx --conf-path=/data/etc/nginx/nginx.conf --error-log-path=/data/local/log/nginx/error.log --pid-path=/data/local/log/nginx.pid --http-log-path=/data/local/log/nginx/access.log --http-client-body-temp-path=/var/run --http-proxy-temp-path=/var/run --http-fastcgi-temp-path=/var/run --http-uwsgi-temp-path=/var/run --http-scgi-temp-path=/var/run --with-cc=/toolchain/0932-x86-2011-11git/usr/bin/i686-linux-gcc --with-cpp=/toolchain/0932-x86-2011-11git/usr/bin/i686-linux-g++ --user=nobody --with-pcre --with-poll_module --with-select_module --with-ipv6 --with-http_ssl_module --with-http_spdy_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_auth_request_module --with-http_random_index_module --with-http_secure_link_module --with-http_degradation_module --with-http_stub_status_module --with-zlib= --with-openssl=

Change History (2)

comment:1 by Maxim Dounin, 6 years ago

Please make sure you are building unmodified nginx. What is, make sure there are no 3rd party patches, including ones to support cross-compilation, and you are building nginx on the target host. If the problem persists, please provide full ./configure output, and the objs/autoconf.err file from the build.

comment:2 by Maxim Dounin, 6 years ago

Resolution: worksforme
Status: newclosed

Feedback timeout. The problem is believed to be due to 3rd party patches to support cross-compilation.

Note: See TracTickets for help on using tickets.