Opened 6 years ago

Closed 6 years ago

#659 closed defect (invalid)

Incomplete dependencies on NGINX RPM for CentOS7

Reported by: Davi Garcia Owned by:
Priority: major Milestone:
Component: nginx-package Version: 1.6.x
Keywords: Cc:
uname -a: Linux localhost.localdomain 3.10.0-123.9.2.el7.x86_64 #1 SMP Tue Oct 28 18:05:26 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.6.2
built by gcc 4.8.2 20140120 (Red Hat 4.8.2-16) (GCC)
TLS SNI support enabled
configure arguments: --prefix=/usr/share/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --http-client-body-temp-path=/var/lib/nginx/tmp/client_body --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-uwsgi-temp-path=/var/lib/nginx/tmp/uwsgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --pid-path=/run/nginx.pid --lock-path=/run/lock/subsys/nginx --user=nginx --group=nginx --with-file-aio --with-ipv6 --with-http_ssl_module --with-http_spdy_module --with-http_realip_module --with-http_addition_module --with-http_xslt_module --with-http_image_filter_module --with-http_geoip_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_degradation_module --with-http_stub_status_module --with-http_perl_module --with-mail --with-mail_ssl_module --with-pcre --with-google_perftools_module --with-debug --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic' --with-ld-opt='-Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-E'

Description

The official rpm package provided by NGINX repository does not include complete library dependencies for CentOS 7. This is the summary of yum install command:

Installed:
  nginx.x86_64 1:1.6.2-4.el7                                                    

Dependency Installed:
  GeoIP.x86_64 0:1.5.0-9.el7                                                    
  fontconfig.x86_64 0:2.10.95-7.el7                                             
  fontpackages-filesystem.noarch 0:1.44-8.el7                                   
  gd.x86_64 0:2.0.35-26.el7                                                     
  gperftools-libs.x86_64 0:2.1-1.el7                                            
  libX11.x86_64 0:1.6.0-2.1.el7                                                 
  libX11-common.noarch 0:1.6.0-2.1.el7                                          
  libXau.x86_64 0:1.0.8-2.1.el7                                                 
  libXpm.x86_64 0:3.5.10-5.1.el7                                                
  libjpeg-turbo.x86_64 0:1.2.90-5.el7                                           
  libpng.x86_64 2:1.5.13-5.el7                                                  
  libunwind.x86_64 0:1.1-3.el7                                                  
  libxcb.x86_64 0:1.9-5.el7                                                     
  nginx-filesystem.noarch 1:1.6.2-4.el7

After install nginx packages and the current dependencies, the service does not start:

[root@localhost yum.repos.d]# systemctl status nginx
nginx.service - The nginx HTTP and reverse proxy server
   Loaded: loaded (/usr/lib/systemd/system/nginx.service; disabled)
   Active: failed (Result: exit-code) since Mon 2014-11-10 13:41:52 BRST; 16s ago
  Process: 26418 ExecStartPre=/usr/sbin/nginx -t (code=exited, status=127)

Nov 10 13:41:52 localhost.localdomain nginx[26418]: /usr/sbin/nginx: error while loading shared libraries: libxslt.so.1: cannot open shared object file: No such file or directory
Nov 10 13:41:52 localhost.localdomain systemd[1]: nginx.service: control process exited, code=exited status=127
Nov 10 13:41:52 localhost.localdomain systemd[1]: Failed to start The nginx HTTP and reverse proxy server.
Nov 10 13:41:52 localhost.localdomain systemd[1]: Unit nginx.service entered failed state.

The issue is solved by installing libxslt package. This should be included in the nginx rpm dependencies.

[root@localhost yum.repos.d]# systemctl status nginx
nginx.service - The nginx HTTP and reverse proxy server
   Loaded: loaded (/usr/lib/systemd/system/nginx.service; disabled)
   Active: active (running) since Mon 2014-11-10 13:43:42 BRST; 2s ago
  Process: 26575 ExecStart=/usr/sbin/nginx (code=exited, status=0/SUCCESS)
  Process: 26574 ExecStartPre=/usr/sbin/nginx -t (code=exited, status=0/SUCCESS)
 Main PID: 26578 (nginx)
   CGroup: /system.slice/nginx.service
           ├─26578 nginx: master process /usr/sbin/nginx
           └─26579 nginx: worker process

Nov 10 13:43:42 localhost.localdomain systemd[1]: Starting The nginx HTTP and reverse proxy server...
Nov 10 13:43:42 localhost.localdomain nginx[26574]: nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
Nov 10 13:43:42 localhost.localdomain nginx[26574]: nginx: configuration file /etc/nginx/nginx.conf test is successful
Nov 10 13:43:42 localhost.localdomain systemd[1]: Failed to read PID from file /run/nginx.pid: Invalid argument
Nov 10 13:43:42 localhost.localdomain systemd[1]: Started The nginx HTTP and reverse proxy server.

Change History (2)

comment:1 by thresh, 6 years ago

This is not an official nginx package from our repository.

comment:2 by Maxim Dounin, 6 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.