Opened 4 years ago

Closed 4 years ago

#682 closed defect (invalid)

fastcgi problem under 42 CPU cores

Reported by: www.google.com/accounts/o8/id?id=AItOawm54tCD-IGdMd1q1iv83tkx7e3Zc3Iwo1c Owned by:
Priority: blocker Milestone: 1.7
Component: nginx-core Version: 1.7.x
Keywords: Cc:
uname -a: Linux phoibe 3.13.0-30-generic #55~precise1-Ubuntu SMP Fri Jul 4 21:52:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.7.6 built by gcc 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) TLS SNI support enabled configure arguments: --prefix=/opt/nginx --with-http_ssl_module --with-http_flv_module --with-http_mp4_module --add-module=../ngx_devel_kit-0.2.19 --add-module=../lua-nginx-module-0.9.13rc1

Description

Yesterday we used 42 CPU cores on our server. We had a lot of traffic and we plan to install 62 cores. But with 42 cores nginx has problems to open the socket file or the 127.0.0.1:9000 port.
Scaling our server down to 32 cores everything works fine.
We got the following log entries:
socket version:
[error] 5172#0: *215354 connect() to unix:/tmp/php5-fpm.sock failed (11: Resource temporarily unavailable) while connecting to upstream
port version:
[error] 10178#0: *598467 upstream timed out (110: Connection timed out) while connecting to upstream
Is there a limit and how is the limit? If there is a limit, can you set the limit up?

Change History (1)

comment:1 Changed 4 years ago by mdounin

  • Resolution set to invalid
  • Status changed from new to closed

Your upstream server is overloaded, not a bug in nginx.

Note: See TracTickets for help on using tickets.