Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#722 closed defect (invalid)

invalid spdy syn_reply

Reported by: patrick.ducksong@… Owned by:
Priority: minor Milestone: 1.7.10
Component: nginx-core Version: 1.7.x
Keywords: Cc:
uname -a:
nginx -V: not sure

Description

Hi - I'm a firefox networking developer.

We've got a user reported problem setting up owncloud and fronting it with spdy enabled nginx.

After some investigation, it comes down to the server generating a SYN_REPLY that is malformed. In particular the length of the set-cookie value is encoded too short and that corrupts interpretation of the name/value header block. You can communicate with the reporter and get a login for an easy reproduction of the problem via the mozilla bugzilla instance

https://bugzilla.mozilla.org/show_bug.cgi?id=1133598

its not clear which version of nginx is being run

Change History (4)

comment:1 Changed 5 years ago by www.google.com/accounts/o8/id?id=AItOawkT2ipeUYUMTVtXFZR1kDr7n4Kd-XPKfeA

I'm the reporter of the problem at bugzilla.
The problem is with Nginx v1.6.2 on Raspbian (Debian wheezy) as stated in the bug report on bugzilla.

comment:2 Changed 5 years ago by vbart

  • Resolution set to invalid
  • Status changed from new to closed

I'm sure your problem is already fixed by revision 34d460c5d186 in nginx 1.7.2. So you should update nginx to the latest version.

comment:3 Changed 5 years ago by patrick.ducksong@…

thanks

comment:4 Changed 5 years ago by www.google.com/accounts/o8/id?id=AItOawkT2ipeUYUMTVtXFZR1kDr7n4Kd-XPKfeA

Just build and installed 1.7.10 and it's confirmed fixed!
Guess I should have read http://nginx.com/blog/nginx-1-6-1-7-released/ before choosing between stable and mainline.

Note: See TracTickets for help on using tickets.