Opened 5 years ago

Closed 5 years ago

#747 closed defect (duplicate)

access_log defined with a prefixing variable is concatenated with prefix

Reported by: https://stackoverflow.com/users/573152/bernard-rosset Owned by:
Priority: minor Milestone:
Component: nginx-module Version: 1.6.x
Keywords: access_log log logs Cc:
uname -a: Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.63-2+deb7u1 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.6.3 built by gcc 4.7.2 (Debian 4.7.2-5) TLS SNI support enabled configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-http_auth_request_module --with-mail --with-mail_ssl_module --with-file-aio --with-http_spdy_module --with-cc-opt='-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2' --with-ld-opt='-Wl,-z,relro -Wl,--as-needed' --with-ipv6

Description

When defining my access logs with the following:

map $http_user_agent $access_log {
    ~*bot       off;
    default     /var/log/nginx/example.org/access.log;
}

server {
    listen  80;
    listen  [::]:80;

    access_log  $access_log;
}

I end up with the following error:

[crit] 20377#0: *2743 open() "/etc/nginx//var/log/nginx/example.org/access.log" failed (2: No such file or directory) while logging request

Change History (2)

comment:1 Changed 5 years ago by https://stackoverflow.com/users/573152/bernard-rosset

Duplicate of #713

Sorry, I could not find it through my previous search.
To be closed.

Thanks,

comment:2 Changed 5 years ago by pluknet

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this as duplicate of ticket #713.

Note: See TracTickets for help on using tickets.