Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#789 closed defect (duplicate)

Program terminated with signal SIGSEGV, Segmentation fault.

Reported by: pakhom706@… Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.8.x
Keywords: Cc:
uname -a: FreeBSD *** 9.3-RELEASE-p21 FreeBSD 9.3-RELEASE-p21
nginx -V: nginx version: nginx/1.8.0
built with OpenSSL 1.0.2c 12 Jun 2015
TLS SNI support enabled
configure arguments: --prefix=/usr/local/etc/nginx --prefix=/usr/local/etc/nginx --with-cc-opt='-I /usr/local/include' --with-ld-opt='-L /usr/local/lib' --conf-path=/usr/local/etc/nginx/nginx.conf --sbin-path=/usr/local/sbin/nginx --pid-path=/var/run/nginx.pid --error-log-path=/var/log/nginx-error.log --user=www --group=www --with-debug --http-client-body-temp-path=/var/tmp/nginx/client_body_temp --http-fastcgi-temp-path=/var/tmp/nginx/fastcgi_temp --http-proxy-temp-path=/var/tmp/nginx/proxy_temp --http-scgi-temp-path=/var/tmp/nginx/scgi_temp --http-uwsgi-temp-path=/var/tmp/nginx/uwsgi_temp --http-log-path=/var/log/nginx-access.log --with-http_dav_module --with-http_flv_module --with-http_gzip_static_module --with-http_gunzip_module --with-http_mp4_module --with-http_realip_module --with-http_stub_status_module --with-http_sub_module --with-http_xslt_module --with-pcre --add-module=/var/fs/build/usr/ports/www/nginx/work/nginx-rtmp-module-1.1.7 --with-http_spdy_module --with-http_ssl_module

Description (last modified by Maxim Dounin)

Worker process constantly exited on signal 11 with different reasons:

[New process 104318]
[New Thread 803408400 (LWP 102979)]
[New LWP 104318]
Core was generated by `nginx'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x0000000000445b56 in ngx_ssl_new_session (ssl_conn=0x80340d800, sess=0x8034e8680)
    at src/event/ngx_event_openssl.c:2309
2309    src/event/ngx_event_openssl.c: No such file or directory.
(gdb) bt
#0  0x0000000000445b56 in ngx_ssl_new_session (ssl_conn=0x80340d800, sess=0x8034e8680)
    at src/event/ngx_event_openssl.c:2309
#1  0x0000000800e4f5b1 in ssl_update_cache () from /lib/libssl.so.8
#2  0x0000000800e2d062 in ssl3_accept () from /lib/libssl.so.8
#3  0x0000000000442da6 in ngx_ssl_handshake (c=0x8037cc528) at src/event/ngx_event_openssl.c:1093
#4  0x000000000044346d in ngx_ssl_handshake_handler (ev=0x8036ddb90) at src/event/ngx_event_openssl.c:1245
#5  0x00000000004331c0 in ngx_event_process_posted (cycle=0x8034fd050, posted=0xe86670 <ngx_posted_events>)
    at src/event/ngx_event_posted.c:33
#6  0x0000000000430a86 in ngx_process_events_and_timers (cycle=0x8034fd050) at src/event/ngx_event.c:265
#7  0x000000000043db8b in ngx_worker_process_cycle (cycle=0x8034fd050, data=0x2)
    at src/os/unix/ngx_process_cycle.c:767
#8  0x000000000043ab01 in ngx_spawn_process (cycle=0x8034fd050, proc=0x43d990 <ngx_worker_process_cycle>, data=0x2, 
    name=0x533e09 "worker process", respawn=-3) at src/os/unix/ngx_process.c:198
#9  0x000000000043c979 in ngx_start_worker_processes (cycle=0x8034fd050, n=8, type=-3)
    at src/os/unix/ngx_process_cycle.c:357
#10 0x000000000043c00a in ngx_master_process_cycle (cycle=0x8034fd050) at src/os/unix/ngx_process_cycle.c:129
#11 0x000000000040841b in main (argc=3, argv=0x7fffffffed18) at src/core/nginx.c:419
(gdb) 

another dump:

Core was generated by `nginx'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x0000000801ee4f9c in ?? ()
(gdb) bt
#0  0x0000000801ee4f9c in ?? ()
#1  0x000000000042b272 in ngx_resolver_process_ptr (
    r=<error reading variable: Cannot access memory at address 0xec>, 
    buf=<error reading variable: Cannot access memory at address 0xe4>, 
    n=<error reading variable: Cannot access memory at address 0xdc>, 
    ident=<error reading variable: Cannot access memory at address 0xd4>, 
    code=<error reading variable: Cannot access memory at address 0xcc>, 
    nan=<error reading variable: Cannot access memory at address 0xc4>)
    at src/core/ngx_resolver.c:2220
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
(gdb) 

one more coredump:

[New process 101212]
Core was generated by `nginx'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x000000000042c49a in ngx_udp_connect (uc=<error reading variable: Cannot access memory at address 0x2ca>)
    at src/core/ngx_resolver.c:3070
3070    src/core/ngx_resolver.c: No such file or directory.
(gdb) bt
#0  0x000000000042c49a in ngx_udp_connect (uc=<error reading variable: Cannot access memory at address 0x2ca>)
    at src/core/ngx_resolver.c:3070
Backtrace stopped: Cannot access memory at address 0x30a

I don't know what preceded it.
NGINX statistics:

Active connections: 46714 
server accepts handled requests
 111678 111678 298032 

Attachments (1)

nginxseg15785.txt (9.1 KB ) - added by pakhom706@… 5 years ago.
nginx debug log

Download all attachments as: .zip

Change History (3)

by pakhom706@…, 5 years ago

Attachment: nginxseg15785.txt added

nginx debug log

comment:1 by Maxim Dounin, 5 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

First backtrace looks like a duplicate of ticket #235, see the first comment to the ticket for detailed description and a workaround. Other core files seems to be corrupted.

comment:2 by pakhom706@…, 5 years ago

Workaround from #235 has helped in my situation.
Thanks

Note: See TracTickets for help on using tickets.