Opened 4 years ago

Closed 4 years ago

#799 closed defect (invalid)

return 501 if post data "_ action=_"

Reported by: sp55aa.org@… Owned by:
Priority: critical Milestone:
Component: nginx-core Version: 1.8.x
Keywords: 501 action post Cc:
uname -a: Linux _ 2.6.16.60-0.21-_-100515 #1 SMP Wed May 12 11:46:34 CST 2010 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.8.0 built by gcc 4.1.2 20070115 (prerelease) (SUSE Linux) built with OpenSSL 1.0.2c 12 Jun 2015 TLS SNI support enabled configure arguments: --prefix=/usr/local/app/nginx --without-http_rewrite_module --with-http_ssl_module --with-openssl=contrib/openssl-1.0.2c --with-http_sub_module --add-module=contrib/nginx_menshen_module

Description

$ curl -d '_ action=_' 'http://127.0.0.1:18082'
<html>
<head><title>501 Not Implemented</title></head>
<body bgcolor="white">
<center><h1>501 Not Implemented</h1></center>
<hr><center>nginx/1.8.0</center>
</body>
</html>

nginx.conf:
server {

listen 18082;
server_name _;
location / {

proxy_pass http://127.0.0.1;

}

}

Change History (3)

comment:1 follow-up: Changed 4 years ago by mdounin

The only case when nginx returns 501 is when client tries to use unknown Transfer-Encoding. If you see such a behaviour based on a POST data contents - it's likely caused by a 3rd party module you use. Please try reproducing without any 3rd party modules/patches compiled in.

comment:2 in reply to: ↑ 1 Changed 4 years ago by sp55aa.org@…

Replying to mdounin:

The only case when nginx returns 501 is when client tries to use unknown Transfer-Encoding. If you see such a behaviour based on a POST data contents - it's likely caused by a 3rd party module you use. Please try reproducing without any 3rd party modules/patches compiled in.

thanks! nginx_menshen_module blocks the post request

comment:3 Changed 4 years ago by mdounin

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for confirming, closing this ticket.

Note: See TracTickets for help on using tickets.