Opened 5 years ago

Closed 5 years ago

#811 closed defect (worksforme)

http2 auth not working

Reported by: Gunter Grodotzki Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.9.x
Keywords: http2, auth Cc:
uname -a: Linux XXXXXX 3.13.0-042stab092.3 #1 SMP Sun Jul 20 13:27:24 MSK 2014 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.9.5 built by gcc 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04) built with LibreSSL 2.3.0 TLS SNI support enabled configure arguments: --prefix=/usr/share/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --http-log-path=/var/log/nginx/access.log --error-log-path=/var/log/nginx/error.log --lock-path=/var/lock/nginx.lock --pid-path=/run/nginx.pid --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-proxy-temp-path=/var/lib/nginx/proxy --without-select_module --without-poll_module --with-file-aio --with-ipv6 --with-pcre=../pcre-8.37 --with-pcre-jit --with-md5-asm --with-sha1-asm --with-zlib=../zlib-1.2.8 --with-zlib-asm=pentiumpro --with-openssl=../libressl-2.3.0 --with-ld-opt=-lrt --with-http_ssl_module --with-http_v2_module --with-http_realip_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_auth_request_module --with-http_stub_status_module --without-http_ssi_module --without-http_userid_module --without-http_geo_module --without-http_split_clients_module --without-http_referer_module --without-http_uwsgi_module --without-http_scgi_module --without-http_memcached_module --without-http_empty_gif_module

Description

A simple auth-basic setup only works via cURL (related to #809) but not via Chrome (http2):

auth_basic "/dev/null";
auth_basic_user_file /etc/nginx/htpasswd.conf;

Change History (1)

comment:1 by Valentin V. Bartenev, 5 years ago

Resolution: worksforme
Status: newclosed

I've just tested in Chromium 45.0.2454.101 and Firefox 41.0.1. It works fine with HTTP/2.

Note: See TracTickets for help on using tickets.