Opened 4 years ago

Closed 4 years ago

#878 closed defect (duplicate)

1.8.0 - segfault on debian jessie

Reported by: 0xBF@… Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.8.x
Keywords: Cc:
uname -a: Linux klint 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.8.0 built with OpenSSL 1.0.1k 8 Jan 2015 TLS SNI support enabled configure arguments: --add-module=wallarm/module --prefix=/usr/share/nginx-wallarm --sbin-path=/usr/sbin/nginx-wallarm --conf-path=/etc/nginx-wallarm/nginx.conf --error-log-path=/var/log/nginx-wallarm/error.log --http-client-body-temp-path=/var/lib/nginx-wallarm/body --http-fastcgi-temp-path=/var/lib/nginx-wallarm/fastcgi --http-log-path=/var/log/nginx-wallarm/access.log --http-proxy-temp-path=/var/lib/nginx-wallarm/proxy --http-scgi-temp-path=/var/lib/nginx-wallarm/scgi --http-uwsgi-temp-path=/var/lib/nginx-wallarm/uwsgi --lock-path=/var/lock/nginx-wallarm.lock --pid-path=/run/nginx-wallarm.pid --with-debug --with-pcre-jit --with-ipv6 --with-http_addition_module --with-http_auth_request_module --with-http_geoip_module --with-http_gzip_static_module --with-http_realip_module --with-http_spdy_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --add-module=debian/modules/nginx-upstream-fair --add-module=debian/modules/headers-more-nginx-module --add-module=debian/modules/ngx_http_substitutions_filter_module

Description

Hi!

There is a lot of crashes on Debian Jessie after upgrade from 1.6.x to 1.8.0:

stack trace:

Thread 1 (Thread 0x7f260fe21740 (LWP 6616)):
#0  ngx_ssl_new_session (ssl_conn=0x25429f0, sess=0x2543760) at src/event/ngx_event_openssl.c:2310
#1  0x00007f260ef01fb0 in ?? () from /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0
#2  0x00000000025429f0 in ?? ()
#3  0x0000000000000003 in ?? ()
#4  0x0000000000000003 in ?? ()
#5  0x000000000042da50 in ?? () at src/event/ngx_event_openssl.c:508
#6  0x00007f260eedfcc1 in ?? () from /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0
#7  0x000000000042f789 in ngx_ssl_handshake (c=c@entry=0x2358eb0) at src/event/ngx_event_openssl.c:1093
#8  0x000000000042fb13 in ngx_ssl_handshake_handler (ev=0x23c3020) at src/event/ngx_event_openssl.c:1245
#9  0x0000000000423d53 in ngx_event_process_posted (cycle=cycle@entry=0x2147410, posted=0x6e6a50 <ngx_posted_events>) at src/event/ngx_event_posted.c:33
#10 0x000000000042385b in ngx_process_events_and_timers (cycle=cycle@entry=0x2147410) at src/event/ngx_event.c:265
#11 0x000000000042a2bf in ngx_worker_process_cycle (cycle=cycle@entry=0x2147410, data=data@entry=0x2) at src/os/unix/ngx_process_cycle.c:767
#12 0x0000000000428c9a in ngx_spawn_process (cycle=0x2147410, proc=0x42a200 <ngx_worker_process_cycle>, data=0x2, name=0x4a3a36 "worker process", respawn=2)
    at src/os/unix/ngx_process.c:198
#13 0x000000000042b73e in ngx_reap_children (cycle=<optimized out>) at src/os/unix/ngx_process_cycle.c:620
#14 ngx_master_process_cycle (cycle=0x2147410) at src/os/unix/ngx_process_cycle.c:173
#15 0x0000000000409173 in main (argc=<optimized out>, argv=<optimized out>) at src/core/nginx.c:419

Maybe there is the bug, already fixed in 1.9.6, because:

  • there is ssl_session_cache parameter used in one of vhosts.
  • upgrate to 1.9.9 solve problem

Change History (1)

comment:1 Changed 4 years ago by mdounin

  • Resolution set to duplicate
  • Status changed from new to closed

Stack trace suggests this is a duplicate of ticket #235, the problem fixed in nginx 1.9.6.

Note: See TracTickets for help on using tickets.