Opened 4 years ago

Closed 4 years ago

#919 closed defect (duplicate)

duplicate Vary: Accept-Encoding header

Reported by: ruudboon@… Owned by:
Priority: minor Milestone:
Component: nginx-module Version: 1.9.x
Keywords: Vary: Accept-Encoding, duplicate Vary Cc:
uname -a: FreeBSD host.host 10.2-RELEASE-p7 FreeBSD 10.2-RELEASE-p7 #0: Mon Nov 2 14:19:39 UTC 2015 root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
nginx -V: nginx version: nginx/1.9.10
built with OpenSSL 1.0.1l-freebsd 15 Jan 2015 (running with OpenSSL 1.0.1p-freebsd 9 Jul 2015)
TLS SNI support enabled
configure arguments: --prefix=/usr/local/etc/nginx --with-cc-opt='-I /usr/local/include' --with-ld-opt='-L /usr/local/lib' --conf-path=/usr/local/etc/nginx/nginx.conf --sbin-path=/usr/local/sbin/nginx --pid-path=/var/run/nginx.pid --error-log-path=/var/log/nginx-error.log --user=www --group=www --with-ipv6 --http-client-body-temp-path=/var/tmp/nginx/client_body_temp --http-fastcgi-temp-path=/var/tmp/nginx/fastcgi_temp --http-proxy-temp-path=/var/tmp/nginx/proxy_temp --http-scgi-temp-path=/var/tmp/nginx/scgi_temp --http-uwsgi-temp-path=/var/tmp/nginx/uwsgi_temp --http-log-path=/var/log/nginx-access.log --with-http_stub_status_module --with-pcre --with-http_v2_module --with-http_ssl_module

Description

The reverse proxy add another Accept-Encoding to the vary header, even when the header is already there.
Resulting in Vary: Accept-Encoding Accept-Encoding

Change History (2)

comment:1 by Maxim Dounin, 4 years ago

Duplicate of #875.

comment:2 by Maxim Dounin, 4 years ago

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.