Opened 5 years ago

Closed 5 years ago

#932 closed defect (duplicate)

Latest mainline won't compile against openssl-1.1.0-pre4

Reported by: dave.qccareerschool.com@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.9.x
Keywords: openssl Cc:
uname -a: Linux sites.qccareerschool.com 2.6.32-573.18.1.el6.x86_64 #1 SMP Tue Feb 9 22:46:17 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: unable to build but this is my configure command:
./configure --prefix=/etc/nginx \
--sbin-path=/usr/sbin/nginx \
--conf-path=/etc/nginx/nginx.conf \
--error-log-path=/var/log/nginx/error.log \
--http-log-path=/var/log/nginx/access.log \
--pid-path=/var/run/nginx.pid \
--lock-path=/var/run/nginx.lock \
--http-client-body-temp-path=/var/cache/nginx/client_temp \
--http-proxy-temp-path=/var/cache/nginx/proxy_temp \
--http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp \
--http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp \
--http-scgi-temp-path=/var/cache/nginx/scgi_temp \
--user=nginx \
--group=nginx \
--with-http_ssl_module \
--with-http_realip_module \
--with-http_addition_module \
--with-http_sub_module \
--with-http_dav_module \
--with-http_flv_module \
--with-http_mp4_module \
--with-http_gunzip_module \
--with-http_gzip_static_module \
--with-http_random_index_module \
--with-http_secure_link_module \
--with-http_stub_status_module \
--with-http_auth_request_module \
--with-mail \
--with-mail_ssl_module \
--with-file-aio \
--with-ipv6 \
--with-http_v2_module \
--with-http_geoip_module \
--with-openssl=/usr/local/src/openssl-1.1.0-pre4 \
--with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=native'

Description

OpenSSL has released their first 1.1.0 beta (feature complete/feature freeze).

I can't get nginx 1.9.12 to compile against it:

cc -c -pipe  -O -W -Wall -Wpointer-arith -Wno-unused-parameter -Werror -g -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=native -I src/core -I src/event -I src/event/modules -I src/os/unix -I /usr/local/src/openssl-1.1.0-pre4/.openssl/include -I objs \
                -o objs/src/event/ngx_event_openssl.o \
                src/event/ngx_event_openssl.c
cc1: warnings being treated as errors
src/event/ngx_event_openssl.c: In function ‘ngx_ssl_init’:
src/event/ngx_event_openssl.c:112: error: ‘OPENSSL_config’ is deprecated (declared at /usr/local/src/openssl-1.1.0-pre4/.openssl/include/openssl/conf.h:140)
src/event/ngx_event_openssl.c: In function ‘ngx_ssl_rsa512_key_callback’:
src/event/ngx_event_openssl.c:753: error: ‘RSA_generate_key’ is deprecated (declared at /usr/local/src/openssl-1.1.0-pre4/.openssl/include/openssl/rsa.h:320)
src/event/ngx_event_openssl.c: In function ‘ngx_ssl_connection_error’:
src/event/ngx_event_openssl.c:1959: error: ‘SSL_R_SSLV3_ALERT_UNEXPECTED_MESSAGE’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1959: error: (Each undeclared identifier is reported only once
src/event/ngx_event_openssl.c:1959: error: for each function it appears in.)
src/event/ngx_event_openssl.c:1960: error: ‘SSL_R_SSLV3_ALERT_BAD_RECORD_MAC’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1961: error: ‘SSL_R_TLSV1_ALERT_DECRYPTION_FAILED’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1962: error: ‘SSL_R_TLSV1_ALERT_RECORD_OVERFLOW’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1963: error: ‘SSL_R_SSLV3_ALERT_DECOMPRESSION_FAILURE’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1964: error: ‘SSL_R_SSLV3_ALERT_HANDSHAKE_FAILURE’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1965: error: ‘SSL_R_SSLV3_ALERT_NO_CERTIFICATE’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1966: error: ‘SSL_R_SSLV3_ALERT_BAD_CERTIFICATE’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1967: error: ‘SSL_R_SSLV3_ALERT_UNSUPPORTED_CERTIFICATE’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1968: error: ‘SSL_R_SSLV3_ALERT_CERTIFICATE_REVOKED’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1969: error: ‘SSL_R_SSLV3_ALERT_CERTIFICATE_EXPIRED’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1970: error: ‘SSL_R_SSLV3_ALERT_CERTIFICATE_UNKNOWN’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1971: error: ‘SSL_R_SSLV3_ALERT_ILLEGAL_PARAMETER’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1972: error: ‘SSL_R_TLSV1_ALERT_UNKNOWN_CA’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1973: error: ‘SSL_R_TLSV1_ALERT_ACCESS_DENIED’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1974: error: ‘SSL_R_TLSV1_ALERT_DECODE_ERROR’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1975: error: ‘SSL_R_TLSV1_ALERT_DECRYPT_ERROR’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1976: error: ‘SSL_R_TLSV1_ALERT_EXPORT_RESTRICTION’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1977: error: ‘SSL_R_TLSV1_ALERT_PROTOCOL_VERSION’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1978: error: ‘SSL_R_TLSV1_ALERT_INSUFFICIENT_SECURITY’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1979: error: ‘SSL_R_TLSV1_ALERT_INTERNAL_ERROR’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1980: error: ‘SSL_R_TLSV1_ALERT_USER_CANCELLED’ undeclared (first use in this function)
src/event/ngx_event_openssl.c:1981: error: ‘SSL_R_TLSV1_ALERT_NO_RENEGOTIATION’ undeclared (first use in this function)
src/event/ngx_event_openssl.c: In function ‘ngx_ssl_session_cache’:
src/event/ngx_event_openssl.c:2124: error: passing argument 2 of ‘SSL_CTX_sess_set_get_cb’ from incompatible pointer type
/usr/local/src/openssl-1.1.0-pre4/.openssl/include/openssl/ssl.h:723: note: expected ‘struct SSL_SESSION * (*)(struct ssl_st *, const unsigned char *, int,  int *)’ but argument is of type ‘struct SSL_SESSION * (*)(struct SSL *, u_char *, int,  int *)’
src/event/ngx_event_openssl.c: In function ‘ngx_ssl_session_id_context’:
src/event/ngx_event_openssl.c:2146: error: storage size of ‘md’ isn’t known
src/event/ngx_event_openssl.c:2212: error: implicit declaration of function ‘EVP_MD_CTX_cleanup’
src/event/ngx_event_openssl.c:2146: error: unused variable ‘md’
make[1]: *** [objs/src/event/ngx_event_openssl.o] Error 1
make[1]: Leaving directory `/usr/local/src/nginx-1.9.12'
make: *** [build] Error 2

Change History (1)

comment:1 by Maxim Dounin, 5 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #860.

Note: See TracTickets for help on using tickets.