Opened 5 years ago

Closed 5 years ago

#935 closed task (duplicate)

Disable SSL3 by default

Reported by: dns2utf8@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.8.x
Keywords: default config ssl3 tls poodle Cc:
uname -a: Linux glider 4.4.5-1-ARCH #1 SMP PREEMPT Thu Mar 10 07:38:19 CET 2016 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.8.1
built with OpenSSL 1.0.2g 1 Mar 2016
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --conf-path=/etc/nginx/nginx.conf --sbin-path=/usr/bin/nginx --pid-path=/run/nginx.pid --lock-path=/run/lock/nginx.lock --user=http --group=http --http-log-path=/var/log/nginx/access.log --error-log-path=stderr --http-client-body-temp-path=/var/lib/nginx/client-body --http-proxy-temp-path=/var/lib/nginx/proxy --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --with-imap --with-imap_ssl_module --with-ipv6 --with-pcre-jit --with-file-aio --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_degradation_module --with-http_flv_module --with-http_geoip_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_realip_module --with-http_secure_link_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_spdy_module

Description

I ran into the issue of SSL3 and having a public server with the default config and the

cypher_suite HIGH:!MD5;

What I did not know was: ssl3 is still active.

Can we make it disabled by default, so the admin would have to enable it if needed?

ssl_protocols {SSL3} TLSv1 TLSv1.1 TLSv1.2;

The reason in my case was an alert from CERT about https://poodle.io/

Change History (1)

comment:1 by Valentin V. Bartenev, 5 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #920.

Note: See TracTickets for help on using tickets.