Opened 5 years ago

Closed 5 years ago

#949 closed defect (duplicate)

Very intermittent 400 errors

Reported by: barber.chris21@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.8.x
Keywords: Cc: barber.chris21@…
uname -a: Linux ip-x-x-x-x.xx-xxxx-xx.compute.internal 3.10.0-229.14.1.el7.x86_64 #1 SMP Tue Aug 25 11:21:22 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.8.1
built by gcc 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC)
built with OpenSSL 1.0.1e-fips 11 Feb 2013
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-http_auth_request_module --with-mail --with-mail_ssl_module --with-file-aio --with-ipv6 --with-http_spdy_module --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic'

Description

Our current nginx setup uses SSL combined with PKI client validation. Randomly (and not readily reproducible) the user is served a 400 error and the following appears in the log (we have the nginx-debug package installed and debug flagged on the error log):

2016/04/08 13:10:19 [info] 24524#0: *7023 client sent no required SSL certificate while reading client request headers, client: xx.xx.xx.xx, server: xxxxxxx.xx.xx, request: "GET / HTTP/1.1", host: "xxxxxxx.xx.xx"

Googling the issue seems to suggest that there is an incompatibility between our (stable) version of nginx and our version of openssl (1:1.0.1e-51.el7_2.4)

Change History (1)

comment:1 by Maxim Dounin, 5 years ago

Resolution: duplicate
Status: newclosed

This seems to be duplicate of #830. If you are able to reproduce the issue - see comments in the ticket in question for details on how to further debug it (basically, a tcpdump of a failed connection is needed).

Note: See TracTickets for help on using tickets.