Opened 4 years ago

Closed 4 years ago

#962 closed defect (duplicate)

Nginx leaves old socket

Reported by: stickybit.myhm.de@… Owned by:
Priority: major Milestone:
Component: documentation Version: 1.9.x
Keywords: Cc:
uname -a: Linux s1 3.2.0-4-amd64 #1 SMP Debian 3.2.54-2 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.9.14
built by gcc 4.7.2 (Debian 4.7.2-5)
built with OpenSSL 1.0.1e 11 Feb 2013
TLS SNI support enabled
configure arguments: --prefix=/usr/share/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --pid-path=/var/run/nginx.pid --lock-path=/var/lock/nginx.lock --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --user=www-data --group=www-data --with-ipv6 --with-http_ssl_module --with-http_stub_status_module --with-http_gzip_static_module --with-stream

Description

/etc/nginx/nginx.conf:


stream {
   server {
      listen unix:/var/run/sock1.sock;
      proxy_pass unix:/var/run/sock2.sock;
   }
}

After the stop of nginx remains /var/run/sock1.sock. Nginx will not start afterwards:

bind() to unix:/var/run/sock1.sock failed (98: Address already in use)

Change History (1)

comment:1 by Maxim Dounin, 4 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #753.

Note: See TracTickets for help on using tickets.