Opened 4 years ago

Closed 4 years ago

#976 closed defect (invalid)

unknown directive "gzip" when upgrade from 1.8.0 to 1.9.15 or 1.10.0

Reported by: lamnhat0403@… Owned by:
Priority: minor Milestone:
Component: other Version: 1.9.x
Keywords: Cc:
uname -a: Linux nginx 2.6.32-279.el6.x86_64 #1 SMP Wed Jun 13 18:24:36 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_xslt_module --with-http_image_filter_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --add-module=/data/nginx/nginx-upload-module-2.2 --add-module=/data/nginx/echo-nginx-module-0.41 --with-mail --with-mail_ssl_module --add-module=/data/nginx/headers-more-nginx-module-0.19 --with-openssl=/opt/openssl-1.0.2a/ --add-module=/data/nginx/ngx_pagespeed-1.8.31.4-beta --add-module=/data/nginx/stream-echo-nginx-module-master --with-stream

Description

Hi all,
When I upgraded nginx from 1.8.0 to 1.9.15 (or 1.10.0), "gzip" became unknown directive. I can "make" & "make install" but can not start nginx because of this error:

unknown directive "gzip" in /usr/local/nginx/conf/nginx.conf:24

I have "gzip on;" in http context and work fine with version 1.8.0.

Please help,
Thanks.

Change History (1)

comment:1 by Maxim Dounin, 4 years ago

Resolution: invalid
Status: newclosed

Such effect is known to be caused by some 3rd party modules due to incorrect behaviour of their "config" scripts. In particular, pagespeed was reported to break things (though this breakage was fixed at least in their master repository). Consider upgrading all 3rd party modules you use to latest versions and/or compiling nginx without 3rd party modules.

Note: See TracTickets for help on using tickets.