Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#1390 closed enhancement (duplicate)

Windows compile http_v2_module on download page

Reported by: bugzilla77@… Owned by:
Priority: minor Milestone:
Component: other Version: 1.13.x
Keywords: Cc:
uname -a:
nginx -V: nginx version: nginx/1.13.3 built by cl 16.00.40219.01 for 80x86 built with OpenSSL 1.0.2l 25 May 2017 TLS SNI support enabled configure arguments: --with-cc=cl --builddir=objs.msvc8 --with-debug --prefix= --conf-path=conf/nginx.conf --pid-path=logs/nginx.pid --http-log-path=logs/access.log --error-log-path=logs/error.log --sbin-path=nginx.exe --http-client-body-temp-path=temp/client_body_temp --http-proxy-temp-path=temp/proxy_temp --http-fastcgi-temp-path=temp/fastcgi_temp --http-scgi-temp-path=temp/scgi_temp --http-uwsgi-temp-path=temp/uwsgi_temp --with-cc-opt=-DFD_SETSIZE=1024 --with-pcre=objs.msvc8/lib/pcre-8.40 --with-zlib=objs.msvc8/lib/zlib-1.2.11 --with-select_module --with-http_v2_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_stub_status_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_auth_request_module --with-http_random_index_module --with-http_secure_link_module --with-http_slice_module --with-mail --with-stream --with-openssl=objs.msvc8/lib/openssl-1.0.2l --with-openssl-opt=no-asm --with-http_ssl_module --with-mail_ssl_module --with-stream_ssl_module

Description

Windows compile http_v2_module on download page.

Change History (3)

comment:1 Changed 2 years ago by mdounin

  • Resolution set to duplicate
  • Status changed from new to closed

As can be seen from the nginx -V output provided in the ticket, ngx_http_v2_module is compiled in: ... --with-http_v2_module .... Also, duplicate of #924 (which is already fixed).

comment:2 Changed 2 years ago by bugzilla77@…

So that means the specification problem.

"This module is not built by default, it should be enabled with the --with-http_v2_module configuration parameter."

http://nginx.org/en/docs/http/ngx_http_v2_module.html

comment:3 Changed 2 years ago by ru

This citation refers to building nginx from sources.

Note: See TracTickets for help on using tickets.