Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1451 closed defect (fixed)

proxy_cache_background_update breaks with trailing questionmark

Reported by: amarsuperstar@… Owned by:
Priority: minor Milestone:
Component: other Version: 1.13.x
Keywords: Cc:
uname -a:
nginx -V: nginx version: nginx/1.13.7
root@b232a73b884a:/# nginx -V
nginx version: nginx/1.13.7
built by gcc 6.3.0 20170516 (Debian 6.3.0-18)
built with OpenSSL 1.1.0f 25 May 2017
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-cc-opt='-g -O2 -fdebug-prefix-map=/data/builder/debuild/nginx-1.13.7/debian/debuild-base/nginx-1.13.7=. -specs=/usr/share/dpkg/no-pie-compile.specs -fstack-protector-strong -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fPIC' --with-ld-opt='-specs=/usr/share/dpkg/no-pie-link.specs -Wl,-z,relro -Wl,-z,now -Wl,--as-needed -pie'

Description

With this configuration

server {
  root /var/www/example.com/current/public/;
  
  location / {
    proxy_cache_valid 200 302 1s;
    proxy_ignore_headers Cache-Control;
    proxy_ignore_headers Expires;
    proxy_cache my_cache;
    proxy_cache_use_stale updating error timeout http_500 http_502 http_503 http_504;
    add_header X-Cache-Status $upstream_cache_status;

    proxy_cache_background_update on;
    
    proxy_pass https://someupstream;
  }
}

Requesting a uri with a trailing querystring, e.g. localhost:8080/api? prevents the background update from working and returns constant stale results, which only a server restart can resolve.

$ curl -sD - -o /dev/null "localhost:8080/api?" | grep X-Cache-Status
X-Cache-Status: MISS
$ curl -sD - -o /dev/null "localhost:8080/api?" | grep X-Cache-Status
X-Cache-Status: HIT
$ curl -sD - -o /dev/null "localhost:8080/api?" | grep X-Cache-Status
X-Cache-Status: STALE
$ curl -sD - -o /dev/null "localhost:8080/api?" | grep X-Cache-Status
X-Cache-Status: STALE
$ curl -sD - -o /dev/null "localhost:8080/api?" | grep X-Cache-Status
X-Cache-Status: STALE

If it run with either proxy_cache_background_update removed, or the trailing querystring removed, it works as expected.

Without proxy_cache_background_update:

$ curl -sD - -o /dev/null "localhost:8080/api?" | grep X-Cache-Status
X-Cache-Status: MISS
$ curl -sD - -o /dev/null "localhost:8080/api?" | grep X-Cache-Status
X-Cache-Status: HIT
$ curl -sD - -o /dev/null "localhost:8080/api?" | grep X-Cache-Status
X-Cache-Status: EXPIRED
$ curl -sD - -o /dev/null "localhost:8080/api?" | grep X-Cache-Status
X-Cache-Status: HIT

With proxy_cache_background_update, but no trailing querystring:

$ curl -sD - -o /dev/null "localhost:8080/api" | grep X-Cache-Status
X-Cache-Status: MISS
$ curl -sD - -o /dev/null "localhost:8080/api" | grep X-Cache-Status
X-Cache-Status: HIT
$ curl -sD - -o /dev/null "localhost:8080/api" | grep X-Cache-Status
X-Cache-Status: STALE
$ curl -sD - -o /dev/null "localhost:8080/api" | grep X-Cache-Status
X-Cache-Status: HIT

Seems to be a bug since proxy_cache_background_update changes the caching semantics.


Change History (1)

comment:1 by Roman Arutyunyan, 3 years ago

Resolution: fixed
Status: newclosed

Related to #1430

The issue is already fixed, the fix will appear in nginx-1.13.8 release.

Last edited 3 years ago by Roman Arutyunyan (previous) (diff)
Note: See TracTickets for help on using tickets.