Opened 2 years ago

Closed 2 years ago

#1647 closed defect (duplicate)

Evaluation of multiple regexes brakes back references

Reported by: Andriy Melnyk Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.14.x
Keywords: Cc:
uname -a: Linux myhost 3.10.0-693.5.2.el7.x86_64 #1 SMP Fri Oct 20 20:32:50 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.14.0
built by gcc 4.8.5 20150623 (Red Hat 4.8.5-16) (GCC)
built with OpenSSL 1.0.2k-fips 26 Jan 2017
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib64/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -fPIC' --with-ld-opt='-Wl,-z,relro -Wl,-z,now -pie'

Description

Prerequisite: map with regex, location with regex + capture group, variable which uses both of them

Issue: variable value is broken, particularly back reference is not evaluated/missed

Config:

map $http_content_type $next_proxy_loc {
    "~^multipart/"     "multipart";
    "~^application/"  "application";
    default                 "default";
}

server {
    listen       9888;
    listen       [::]:9888;

    location ~ ^/test/(.+)$ {
        proxy_set_header   Connection "";
        proxy_set_header   Host $host;

        proxy_http_version 1.1;
        proxy_pass         http://127.0.0.1:9777/$next_proxy_loc/$1;
    }
}

Repo steps
curl -sv -o /dev/null http://127.0.0.1:9888/test/test.pdf -H"Content-Type:application/pdf"
proxy_pass => GET /application/ (it should be: GET /application/test.pdf)


curl -sv -o /dev/null http://127.0.0.1:9888/test/myform -H"Content-Type:multipart/form-data"
proxy_pass => GET /multipart/ (it should be: GET /multipart/myform)


But if proxy_pass has only single regex variable, it works fine. For example,

proxy_pass http://127.0.0.1:9777/$1; # works fine, like GET /test.pdf

Change History (1)

comment:1 by Maxim Dounin, 2 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #1285.

Note: See TracTickets for help on using tickets.