Opened 3 months ago

Closed 3 months ago

#1780 closed defect (invalid)

1.16.0-alpine docker image CrashLoop

Reported by: lauksas@… Owned by:
Priority: critical Milestone:
Component: other Version: 1.15.x
Keywords: Docker Cc:
uname -a: Alpine
nginx -V: 1.16.0-alpine

Description

This image throws the error below complaining about the module version.
The line in the nginx.conf file is

load_module /usr/lib/nginx/modules/ndk_http_module.so;

Logged error.

2019/05/09 05:44:17 [emerg] 1#1: module "/usr/lib/nginx/modules/ndk_http_module.so" version 1014002 instead of 1016000 in /etc/nginx/nginx.conf:2

PS: version 1.16 unavailable in the box.

Change History (1)

comment:1 Changed 3 months ago by mdounin

  • Resolution set to invalid
  • Status changed from new to closed

You are trying to load a 3rd party module compiled for different nginx version. This is not going to work, you have to install the module compiled for nginx 1.16.0.

Note: See TracTickets for help on using tickets.