Opened 10 days ago

Closed 10 days ago

#1781 closed defect (invalid)

Does not build on Mac with OpenSSL

Reported by: jay-ouellette@… Owned by:
Priority: minor Milestone:
Component: other Version: 1.15.x
Keywords: Cc:
uname -a: Darwin MW002908.local 15.6.0 Darwin Kernel Version 15.6.0: Thu Jun 21 20:07:40 PDT 2018; root:xnu-3248.73.11~1/RELEASE_X86_64 x86_64
nginx -V: N/A

Change History (1)

comment:1 Changed 10 days ago by mdounin

  • Resolution set to invalid
  • Status changed from new to closed

Likely the problem is due to conflicting OpenSSL header files somewhere in /opt/local/include as used for PCRE library headers. Remove the conflicting header files or consider adding

--with-cc-opt="-I $(pwd)/../${openssl_src_dir}/.openssl/include"

to the configure arguments.

Note: See TracTickets for help on using tickets.