Opened 3 weeks ago

Closed 3 weeks ago

#1940 closed defect (duplicate)

NGINX CONF

Reported by: sebastian.oppe.viveogroup.com@… Owned by:
Priority: minor Milestone:
Component: other Version: 1.16.x
Keywords: index Cc:
uname -a: Linux ip-172-31-33-190.ec2.internal 3.10.0-1062.12.1.el7.x86_64 #1 SMP Tue Feb 4 23:02:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.16.1
built by gcc 4.8.5 20150623 (Red Hat 4.8.5-39) (GCC)
built with OpenSSL 1.0.2k-fips 26 Jan 2017
TLS SNI support enabled
configure arguments: --prefix=/usr/share/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib64/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --http-client-body-temp-path=/var/lib/nginx/tmp/client_body --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-uwsgi-temp-path=/var/lib/nginx/tmp/uwsgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --pid-path=/run/nginx.pid --lock-path=/run/lock/subsys/nginx --user=nginx --group=nginx --with-file-aio --with-ipv6 --with-http_ssl_module --with-http_v2_module --with-http_realip_module --with-stream_ssl_preread_module --with-http_addition_module --with-http_xslt_module=dynamic --with-http_image_filter_module=dynamic --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_degradation_module --with-http_slice_module --with-http_stub_status_module --with-http_perl_module=dynamic --with-http_auth_request_module --with-mail=dynamic --with-mail_ssl_module --with-pcre --with-pcre-jit --with-stream=dynamic --with-stream_ssl_module --with-google_perftools_module --with-debug --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic' --with-ld-opt='-Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-E'

Description

I add 6 site in the same server for app run nodejs and php.
One of the config not fail but server redirecto to a invalid site!
When check config two config file not have ; to end line.
But nginx -t no detect the file with error and load normally.
Example index without ;

server {

root /var/www/html/mysite_blog;

# Add index.php to the list if you are using PHP
index index.html index.htm index.php

.
.
.

When run nginx -t not return error

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

But the problem next is when add new site not work or have problems.
I use certbot-auto and the same don't can see the new site config.

When add ; in all new site run ok and cerbot-detect the site!

Change History (1)

comment:1 by Maxim Dounin, 3 weeks ago

Resolution: duplicate
Status: newclosed

The semicolon after the "index" directive is mandatory. If it is not present, nginx might or might not be able to detect the error, depending on if there is a syntax error or the following line can be interpreted as the "index" directive parameters. Duplicate of #947.

Note: See TracTickets for help on using tickets.