Opened 5 months ago

Closed 5 months ago

#2175 closed defect (duplicate)

autoindex is not compatible with utf-8 characters (1.20.0)

Reported by: https://stackoverflow.com/users/7426482/jimmy-westberg Owned by:
Priority: minor Milestone:
Component: nginx-module Version: 1.19.x
Keywords: autoindex Cc: https://stackoverflow.com/users/7426482/jimmy-westberg
uname -a:
nginx -V: 1.20.0

Description

As described here; https://serverfault.com/q/1062035/454723

I get a 500 error if file path got any (in my case) Swedish characters in the file name or folder name. Removing the autoindex and point to any of those files directly it'll work as intended.

Resolved in my case by making my own index script.

Same behavior when tested on 1.18.x

Change History (1)

comment:1 by Maxim Dounin, 5 months ago

Resolution: duplicate
Status: newclosed

Given the error message in the serverfault question, it looks like you are using Windows. Support for multibyte characters in autoindex on Windows is not currently implemented, see ticket #458.

Note: See TracTickets for help on using tickets.