Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#2177 closed enhancement (duplicate)

Add audio/opus to mime.types

Reported by: xnaas Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.18.x
Keywords: Cc:
uname -a: Linux d11bc9aa38a0 4.19.0-16-amd64 #1 SMP Debian 4.19.181-1 (2021-03-19) x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.18.0
built with OpenSSL 1.1.1i 8 Dec 2020 (running with OpenSSL 1.1.1k 25 Mar 2021)
TLS SNI support enabled
configure arguments: --prefix=/var/lib/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --pid-path=/run/nginx/nginx.pid --lock-path=/run/nginx/nginx.lock --http-client-body-temp-path=/var/lib/nginx/tmp/client_body --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-uwsgi-temp-path=/var/lib/nginx/tmp/uwsgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --with-perl_modules_path=/usr/lib/perl5/vendor_perl --user=nginx --group=nginx --with-threads --with-file-aio --with-http_ssl_module --with-http_v2_module --with-http_realip_module --with-http_addition_module --with-http_xslt_module=dynamic --with-http_image_filter_module=dynamic --with-http_geoip_module=dynamic --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_auth_request_module --with-http_random_index_module --with-http_secure_link_module --with-http_degradation_module --with-http_slice_module --with-http_stub_status_module --with-http_perl_module=dynamic --with-mail=dynamic --with-mail_ssl_module --with-stream=dynamic --with-stream_ssl_module --with-stream_realip_module --with-stream_geoip_module=dynamic --with-stream_ssl_preread_module --add-dynamic-module=/home/buildozer/aports/main/nginx/src/njs-0.5.0/nginx --add-dynamic-module=/home/buildozer/aports/main/nginx/src/ngx_devel_kit-0.3.1/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/ngx_brotli-1.0.0rc/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/ngx_cache_purge-2.5.1/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/nginx-dav-ext-module-3.0.0/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/echo-nginx-module-0.62/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/encrypted-session-nginx-module-0.08/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/ngx-fancyindex-0.5.1/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/headers-more-nginx-module-0.33/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/lua-nginx-module-0.10.19/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/lua-upstream-nginx-module-0.07/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/nchan-1.2.7/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/nginx-http-shibboleth-2.0.1/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/redis2-nginx-module-0.15/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/set-misc-nginx-module-0.32/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/nginx-upload-progress-module-0.9.2/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/nginx-upstream-fair-0.1.3/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/nginx-rtmp-module-1.2.1/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/nginx-vod-module-1.27/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/ngx_http_geoip2_module-3.3/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/naxsi-1.3/naxsi_src --add-dynamic-module=/home/buildozer/aports/main/nginx/src/mod_zip-1.2.0/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/nginx-module-vts-0.1.18/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/traffic-accounting-nginx-module-2.0/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/ngx_http_untar_module-1.0/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/ngx_upstream_jdomain-1.1.5/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/nginx_cookie_flag_module-1.1.0/ --add-dynamic-module=/home/buildozer/aports/main/nginx/src/array-var-nginx-module-0.05/

Description (last modified by xnaas)

I would like to see the following added to mime.types:

audio/opus                                        opus;

Example similar changeset: https://hg.nginx.org/nginx/rev/118885f7a577

Relevant lines: https://github.com/nginx/nginx/blob/master/conf/mime.types#L79-L83

I've love to submit a changeset myself, but I'm afraid I'm utterly lost when it comes to hg.

Change History (3)

comment:1 by xnaas, 5 months ago

Description: modified (diff)

Fixed the code block...my bad.

Last edited 5 months ago by xnaas (previous) (diff)

comment:2 by Maxim Dounin, 5 months ago

Resolution: duplicate
Status: newclosed

From the https://en.wikipedia.org/wiki/Opus_(audio_format) and https://opus-codec.org/, it looks like the .opus extension is used for Opus streams is Ogg containers, and the audio/ogg media type should be used such files. The audio/opus media type is to be used for RTP, not HTTP. Given the above, suggested change looks clearly wrong to me.

A request to add audio/ogg mapping for the .opus extension was previously made in #279, though it was decided not to add it due to low popularity of the files with the .opus extension. It doesn't looks like things changed much since then: .opus files aren't popular and the .opus extension still not even supported by OSes such as macOS and iOS. Though I may be wrong - if you think so (and agree that audio/ogg is the correct MIME type to use), please reopen the #279 ticket and provide some details outlining why you think it worth adding. Alternatively, consider extending your MIME types mapping locally.

Closing this as a duplicate of #279.

Last edited 5 months ago by Maxim Dounin (previous) (diff)

in reply to:  2 comment:3 by xnaas, 5 months ago

Thanks for the reply and links. Understood on the denial.

Replying to Maxim Dounin:

From the https://en.wikipedia.org/wiki/Opus_(audio_format) and https://opus-codec.org/, it looks like the .opus extension is used for Opus streams is Ogg containers, and the audio/ogg media type should be used such files. The audio/opus media type is to be used for RTP, not HTTP. Given the above, suggested change looks clearly wrong to me.

A request to add audio/ogg mapping for the .opus extension was previously made in #279, though it was decided not to add it due to low popularity of the files with the .opus extension. It doesn't looks like things changed much since then: .opus files aren't popular and the .opus extension still not even supported by OSes such as macOS and iOS. Though I may be wrong - if you think so (and agree that audio/ogg is the correct MIME type to use), please reopen the #279 ticket and provide some details outlining why you think it worth adding. Alternatively, consider extending your MIME types mapping locally.

Closing this as a duplicate of #279.

Note: See TracTickets for help on using tickets.