Opened 4 weeks ago

Closed 4 weeks ago

#2241 closed defect (duplicate)

Under special circumstances cause http code 400

Reported by: zhoulin1359@… Owned by:
Priority: minor Milestone:
Component: documentation Version: 1.19.x
Keywords: url Cc:
uname -a: Linux aws-grab03-51209 2.6.32-642.13.1.el6.x86_64 #1 SMP Wed Jan 11 20:56:24 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.14.2
built by gcc 4.4.7 20120313 (Red Hat 4.4.7-23) (GCC)
built with OpenSSL 1.0.1e-fips 11 Feb 2013
TLS SNI support enabled
configure arguments: --prefix=/usr/local/nginx --user=nginx --group=nginx --with-http_ssl_module --with-http_gzip_static_module --http-client-body-temp-path=/usr/local/nginx/tmp/client/ --http-proxy-temp-path=/usr/local/nginx/tmp/proxy/ --http-fastcgi-temp-path=/usr/local/nginx/tmp/fcgi/ --with-poll_module --with-file-aio --with-http_realip_module --with-http_addition_module --with-http_random_index_module --with-pcre --with-http_stub_status_module --http-uwsgi-temp-path=/usr/local/nginx/uwsgi_temp --http-scgi-temp-path=/usr/local/nginx/scgi_temp --add-module=/opt/tools/ngx_devel_kit-0.3.1/ --with-ld-opt=-Wl,-rpath,/usr/local/lj2/lib --add-module=/opt/tools/lua-nginx-module-0.10.15/

Description

Incorrect: curl 'http://nginx.org?a=A H'
normal:curl 'http://nginx.org?a=A C'

Change History (1)

comment:1 by Maxim Dounin, 4 weeks ago

Resolution: duplicate
Status: newclosed

Duplicate of #196.

Note: See TracTickets for help on using tickets.