Opened 7 months ago

Closed 7 months ago

#2356 closed defect (duplicate)

NGINX crashes when renewing certificates with certbot

Reported by: har.dhillon.dmlmarketing.co.uk@… Owned by:
Priority: major Milestone:
Component: nginx-module Version: 1.18.x
Keywords: certbot 50-mod-http-perl Cc:
uname -a: Linux 5.4.0-110-generic #124-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx/1.18.0 (Ubuntu)

Description

NGINX crashes when certbot attempts to renew certificates.
Attempting a dry run with

sudo certbot renew --dry-run

will cause NGINX to stop running.

There appears to be an issue with the nginx Perl module enabled through the nginx-extras package as the the issue was fixed through a solution for a similar problem that can be found here:
https://community.letsencrypt.org/t/nginx-server-fails-after-certbot-renew/142660

by running

sudo rm /etc/nginx/modules-enabled/50-mod-http-perl.conf

Change History (1)

comment:1 by Maxim Dounin, 7 months ago

Resolution: duplicate
Status: newclosed

It looks like you are using Ubuntu 20.04, and it ships buggy Perl 5.30. The issue is fixed in Perl 5.32. Consider upgrading or avoid using the Perl module.

Duplicate of #1831.

Note: See TracTickets for help on using tickets.