Opened 9 years ago

Closed 9 years ago

#27 closed defect (fixed)

Troubles streaming h264/aac not from the beggining

Reported by: Danila Sukharev Owned by: somebody
Priority: minor Milestone:
Component: nginx-core Version: 1.0.x
Keywords: Cc:
uname -a: Windows [5.2.3790] aka 2003 server
nginx -V: nginx: nginx version: nginx/1.0.8
nginx: TLS SNI support enabled
nginx: configure arguments: --builddir=objs.msvc8 --crossbuild=win32 --with-debug --prefix= --conf-path=conf/nginx.conf --pid-path=logs/nginx.pid --http-log-path=logs/access.log --error-log-path=logs/error.log --sbin-path=nginx.exe --http-client-body-temp-path=temp/client_body_temp --http-proxy-temp-path=temp/proxy_temp --http-fastcgi-temp-path=temp/fastcgi_temp --with-cc-opt=-DFD_SETSIZE=1024 --with-pcre=objs.msvc8/lib/pcre-7.9 --with-zlib=objs.msvc8/lib/zlib-1.2.3 --with-select_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_stub_status_module --with-http_flv_module --with-http_mp4_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-mail --with-ipv6 --with-openssl=objs.msvc8/lib/openssl-0.9.8r --with-openssl-opt=enable-tlsext --with-http_ssl_module --with-mail_ssl_module

Description

Steps:

  1. Took the default config from the documentation (mp4 directive)
  2. Placed some mp4 files to the corresponding folder.
  3. Tried to play them not from the beginning.

Happened: player gets the whole clip from start to the point I've forwarded to.
Expected: player gets the clip from the point I've specified.

Comments:

  1. All clips was downloaded from the youtube.
  2. I've checked using mplayer that they are really mp4/h264/aac.
  3. Nothing is in error.log.
  4. I've made sure that moov atom is in the beggining of the clip (used the following guide: http://www.adobe.com/devnet/video/articles/mp4_movie_atom.html)
  5. I've checked that this is not a player issue (tried both console mplayer / flow player).
  6. I've tried to forward using player controls (in this case mplayer uses GET 206) - no luck.
  7. I've tried to use http://URL?start=N - the same.

The only way player works - is when it plays from the very beginning of the file.
Looks like a defect for me; sorry if this is some kind of misconf or whatever.

-- Dan

Change History (7)

comment:1 by is, 9 years ago

Status: newaccepted

Could you give URL of such mp4 file ?

comment:2 by Danila Sukharev, 9 years ago

ftp://support.hopsteam.ru/Media/8.mp4
I've tried on 8 different files, this is the longest one and the most suitable for testing.

comment:3 by is, 9 years ago

I've tested this file with JW player on Unix system without any issues.
Probably this problem is Windows related. I will check soon.

comment:4 by Danila Sukharev, 9 years ago

Just tested the following:

  1. Built nginx 1.0.8 from the sources on Ubuntu.
  2. Share the same clip locally using compiled nginx.

Result: rewind works!

Comments:
I see two possible reasons:

  1. It works in different way on Win vs *nix.
  2. It works locally cause download speed is very high - and rewind works cause clip got cached.

To make sure that this is not #2, I'll also try to reproduce this on *nix system and slow connection.

comment:5 by Danila Sukharev, 9 years ago

Just checked with *nix version on slow channel - play from the specified position works!
So this is definitely looks like a Windows build issue.

-- Dan

comment:6 by is, 9 years ago

This bug should be fixed in nginx-1.1.6.

comment:7 by Maxim Dounin, 9 years ago

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.