Opened 7 years ago

Closed 7 years ago

#31 closed defect (invalid)

error: Failed dependencies: libcrypto.so.0.9.8 is needed by nginx-1.0.5-1_WR4.1.0.0.x86_64

Reported by: www.google.com/accounts/o8/id?id=AItOawnnvnNxJdDle0frIJEdF2Pkc3qbZKm_7LM Owned by: somebody
Priority: blocker Milestone:
Component: nginx-package Version: 1.0.x
Keywords: Cc:
uname -a: Linux TestMachine 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 06:07:29 UTC 2010 i686 GNU/Linux
nginx -V: nginx: nginx version: nginx/1.0.5 nginx: built by gcc 4.4.3 (Ubuntu 4.4.3-4ubuntu5) nginx: configure arguments: --with-pcre=/home/user/workspace/Test/build/INSTALL_STAGE/pcre-7.8/../../pcre-7.8/BUILD/pcre-7.8 --with-zlib=/home/user/workspace/Test/build/INSTALL_STAGE/zlib-1.2.5/../../zlib-1.2.5/BUILD/zlib-1.2.5

Description

Hello,

I am trying to add nginx-1.0.5.tar.gz package to Wind River Linux. The host machine I am using is Ubuntu 10.04.
Nginx package got compiled and it created install directories and files in /usr/local/nginx folder.
But during the final creation of kernel image and RFS we are getting below error.

Installing RPMs into filesystem directory
Preparing... ##################################################
setup ##################################################
error: Failed dependencies:
libcrypto.so.0.9.8 is needed by nginx-1.0.5-1_WR4.1.0.0.x86_64
libcrypto.so.0.9.8(OPENSSL_0.9.8) is needed by nginx-1.0.5-1_WR4.1.0.0.x86_64

I got this this error after adding 'openssl-dev' package to our Ubuntu machine through apt-get. Before adding this package Wind River kernel image and RFS is created successfully.

On analysis I found that in nginx-1.0.5\objs\ngx_auto_config.h, following addtional #defines are setting in the not working source code
#ifndef NGX_OPENSSL_MD5
#define NGX_OPENSSL_MD5 1
#endif

#ifndef NGX_HAVE_OPENSSL_MD5_H
#define NGX_HAVE_OPENSSL_MD5_H 1
#endif

#ifndef NGX_HAVE_MD5
#define NGX_HAVE_MD5 1
#endif

#ifndef NGX_HAVE_SHA1
#define NGX_HAVE_SHA1 1
#endif

#ifndef NGX_HAVE_OPENSSL_SHA1_H
#define NGX_HAVE_OPENSSL_SHA1_H 1
#endif

Could you please tell me what could be the issue. Does nginx looks for the openssl/libcrypto library versions of host machine during configuration and compilation.

Regards
Sivan

Change History (2)

comment:1 Changed 7 years ago by www.google.com/accounts/o8/id?id=AItOawnnvnNxJdDle0frIJEdF2Pkc3qbZKm_7LM

I got this this error after adding 'libssl-dev' package not 'openssl-dev' package to our Ubuntu machine through apt-get.

Regards
Sivan

Last edited 7 years ago by www.google.com/accounts/o8/id?id=AItOawnnvnNxJdDle0frIJEdF2Pkc3qbZKm_7LM (previous) (diff)

comment:2 Changed 7 years ago by fabler

  • Resolution set to invalid
  • Status changed from new to closed
  • First of all do not use trac for questions - it is a bug tracking system. Please send questions to nginx mail list.
  • As for question, yes, nginx may use openssl for md5 and sha1 if openssl libs are available.
Note: See TracTickets for help on using tickets.