Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#555 closed defect (wontfix)

missing fastcgi_param SCRIPT_FILENAME variable in default package conf files

Reported by: Luigi Fan Owned by:
Priority: minor Milestone:
Component: nginx-package Version:
Keywords: fastcgi Cc:
uname -a: Linux li493-216 3.12.9-x86_64-linode37 #1 SMP Mon Feb 3 10:01:02 EST 2014 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.6.0
built by gcc 4.7.2 (Debian 4.7.2-5)
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-http_auth_request_module --with-mail --with-mail_ssl_module --with-file-aio --with-http_spdy_module --with-cc-opt='-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2' --with-ld-opt='-Wl,-z,relro -Wl,--as-needed' --with-ipv6

Description

I updated nginx to 1.6.0 via http://wiki.nginx.org/Install on my Debian Wheezy server, and found that one of the php application "rockmongo" borked. curl -Lv return blank, so does chrome, firefox or other browsers. No error message in nginx access/error log or php-fpm error log.
After googling and comparing the fastcgi_params file in /etc/nginx with nignx 1.4.7 which is packaged by dotdeb, I found that the following line is missing in the default fastcgi_params file provided by 1.6.0 official package:

fastcgi_param  SCRIPT_FILENAME    $request_filename;

I added it back to fastcgi_params, reload, and the rockmongo worked like a charm again.

Please considering fix it, I'd be appreciated if you can do that. Thanks!

Change History (2)

comment:1 by Sergey Budnevitch, 6 years ago

Resolution: wontfix
Status: newclosed

$request_filename for SCRIPT_FILENAME maybe simply wrong. It is usually defined using $fastcgi_script_name variable, but it is better to add correct param with fastcgi_param directive in nginx.conf rather than edit fastcgi_params file.

comment:2 by Valentin V. Bartenev, 6 years ago

There is also fastcgi.conf shipped with fastcgi_param SCRIPT_FILENAME set to $document_root$fastcgi_script_name.

The problem is that debian maintainers merged it into fastcgi_params.

Last edited 6 years ago by Valentin V. Bartenev (previous) (diff)
Note: See TracTickets for help on using tickets.