Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#562 closed enhancement (invalid)

error_log does should support variables

Reported by: Julien Gormotte Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.5.x
Keywords: error_log Cc:
uname -a: Linux host.domain.tld 2.6.32-431.17.1.el6.x86_64 #1 SMP Wed May 7 23:32:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.5.13
built by gcc 4.4.7 20120313 (Red Hat 4.4.7-4) (GCC)
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-http_auth_request_module --with-mail --with-mail_ssl_module --with-file-aio --with-ipv6 --with-http_spdy_module --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic'

Description

Hello,

access_log supports variables in the path given, but not error_log.
That seems strange, is it possible to change this ?

Thanks

Change History (3)

comment:1 by Ruslan Ermilov, 6 years ago

Resolution: invalid
Status: newclosed

It's so by design. Variables are only available with HTTP requests, while error_log is not limited to HTTP.

comment:2 by Valentin V. Bartenev, 6 years ago

Even more important that the error log is a critical thing. It must be available all the time.

Let's assume that you have set path to /path/$var/error.log, then where an error during evaluation of $var (e.g. allocating memory for $var) should be logged?

But we may think about variables support for error_log specified in context different from main.

comment:3 by Julien Gormotte, 6 years ago

Yes, my intention was for error_log in server context. It would be great, so i'll be watching release notes hoping some day it will be done :)

Thanks for your answers.

Note: See TracTickets for help on using tickets.