Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#914 closed task (duplicate)

No target 'install_sw' with LibreSSL since nginx 1.9.12

Reported by: macedigital@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.9.x
Keywords: libressl Cc: macedigital@…
uname -a: Linux localhost.localdomain 4.3.5-300.fc23.x86_64 #1 SMP Mon Feb 1 03:18:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.9.12
built by gcc 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC)
built with LibreSSL 2.3.2
TLS SNI support enabled
configure arguments: --prefix=/usr/share/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --http-client-body-temp-path=/var/lib/nginx/tmp/client_body --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-uwsgi-temp-path=/var/lib/nginx/tmp/uwsgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --pid-path=/run/nginx.pid --lock-path=/run/lock/subsys/nginx --user=nginx --group=nginx --with-threads --with-file-aio --with-ipv6 --with-http_ssl_module --with-http_v2_module --with-http_realip_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_slice_module --with-http_stub_status_module --without-select_module --without-poll_module --without-mail_pop3_module --without-mail_imap_module --without-mail_smtp_module --with-stream --with-stream_ssl_module --with-pcre=/tmp/nginx-static-libressl/build/pcre-8.38 --with-pcre-jit --with-openssl=/tmp/nginx-static-libressl/build/libressl-2.3.2 --with-zlib=/tmp/nginx-static-libressl/build/zlib-1.2.8 --with-cc-opt='-fPIC -pie -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic' --with-ld-opt='-Wl,-z,now -lrt'

Description

Due to https://trac.nginx.org/nginx/changeset/6404/nginx/auto/lib/openssl/make#file0 its no longer possible to compile nginx 1.9.12 (unpatched) with libreSSL 2.x.

Problem is calling the make target install_sw which is simply non-existing in LibreSSL. The closest make target I could find in the sources is install-strip (which serves roughly the same purpose of not building documentation files).

Please see https://gist.github.com/macedigital/9a26365c2f63f2aa0324 for details. The purpose is to build on CentOS 7 which doesn't yet supports an OpenSSL version with ALPN.

As the nginx project has a huge standing in the (not only BSD) community, could you ask the LibreSSL maintainers to either provide a make install_sw target which roughly corresponds to the respective OpenSSL project's one; or implement an compile time flag to enable compiling with different (makefile) library implementations (I haven't even tried with WolfSSL yet).

Eventually, it was no problem to build nginx 1.9.12 after patching auto/lib/openssl/make, but I wouldn't be surprised if this problem will come up again.

Change History (2)

comment:1 by Maxim Dounin, 4 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #908.

comment:2 by macedigital@…, 4 years ago

I understand, and sorry for the double-post.

Note: See TracTickets for help on using tickets.