Opened 3 years ago

Closed 3 years ago

#942 closed defect (duplicate)

SSL_shutdown() failed while SSL handshaking

Reported by: anubhav2301@… Owned by:
Priority: critical Milestone:
Component: nginx-core Version: 1.8.x
Keywords: Cc:
uname -a: Linux ip-10-0-0-172 3.0.82-0.7-ec2 #1 SMP Thu Jun 27 13:19:18 UTC 2013 (6efde93) x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.8.1 built by gcc 4.3.4 [gcc-4_3-branch revision 152973] (SUSE Linux) built with OpenSSL 1.0.2g 1 Mar 2016 TLS SNI support enabled configure arguments: --prefix=/usr/local/nginx --with-http_ssl_module --with-openssl=/root/anu/openssl-1.0.2g --with-http_stub_status_module --with-debug --with-pcre=./pcre-8.31 --with-pcre-jit --add-module=nginx-rewrite-request-body-module --add-module=nginx-sticky-module-1.0-rc2 --add-module=agentzh-echo-nginx-module --add-module=lua-nginx-module-0.8.6 --with-http_geoip_module --without-http_memcached_module

Description

Hi,

I'm getting below log entry in nginx error log:

[crit] 25233#0: *658546891 SSL_shutdown() failed (SSL: error:140E0197:SSL routines:SSL_shutdown:shutdown while in init) while SSL handshaking, client: *.*.*.*, server: 0.0.0.0:443

Change History (3)

comment:1 Changed 3 years ago by vbart

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #901.

comment:2 Changed 3 years ago by anubhav2301@…

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Ticket #901 observed with Nginx 1.9.11 with OpenSSL 1.0.2f version and fix has been committed.

I used Nginx 1.8.1 stable version with OpenSSL 1.0.2g stable version. But I am getting error.

Do let me know which version should I use to resolve this issue or what changes I need to do to fix this ?

Please help.

Last edited 3 years ago by anubhav2301@… (previous) (diff)

comment:3 Changed 3 years ago by mdounin

  • Resolution set to duplicate
  • Status changed from reopened to closed

Please avoid reopening duplicate tickets unless you think they are not duplicate. This is clearly not the case.

Note: See TracTickets for help on using tickets.