Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1490 closed defect (duplicate)

NGINX hold request too long, and causes timeout error.

Reported by: justinchiasky@… Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.12.x
Keywords: timeout Cc: justinchiasky@…
uname -a: Linux AWS-PLS-RWT1 2.6.32-642.13.1.el6.centos.plus.x86_64 #1 SMP Thu Jan 12 11:45:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.12.2
built by gcc 4.4.7 20120313 (Red Hat 4.4.7-18) (GCC)
built with OpenSSL 1.0.1e-fips 11 Feb 2013
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib64/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC' --with-ld-opt='-Wl,-z,relro -Wl,-z,now -pie'

Description

Hi,

Last week I upgrade NGINX from 1.10.2 to 1.12.2, but after upgrade, our client occasionally get HTTP STATS 504 gateway timeout error.
Per my checking, this error was caused by NGINX, NGINX hold request too long due to unknown reason before passing request to backend server. This issue never occur when we was using NGINX with version 1.10.2.
Below are information that I got from NGINX access log and error log, please help me to clarify whether this issue is from bug of NGINX. Thanks a lot.

  1. I added $upstream_response_time into log format, and this field is recorded two values, for instance, '60.010, 0.018'. In normal request, this field always has only one value.
  1. When such error occur, there are always have below records in error log file of NGINX.

2018/02/21 09:59:26 [warn] 25458#25458: *551645 upstream server temporarily disabled while connecting to upstream, client: 10.1.185.135, server: _, request: "GET /API/v2/customers HTTP/1.1", upstream: "https://10.104.66.47:443/API/v2/customers", host: "aws-pls-rwt2s.sdi.trendnet.org"
2018/02/21 09:59:26 [error] 25458#25458: *551645 upstream timed out (110: Connection timed out) while connecting to upstream, client: 10.1.185.135, server: _, request: "GET /API/v2/customers HTTP/1.1", upstream: "https://10.104.66.47:443/API/v2/customers", host: "aws-pls-rwt2s.sdi.trendnet.org"

Change History (3)

comment:1 by Maxim Dounin, 3 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #1488.

in reply to:  1 comment:2 by justinchiasky@…, 3 years ago

Replying to mdounin:

Duplicate of #1488.

Hi,

I saw this ticket was marked "closed" due to duplicate of #1488, but I cannot find out #1488.

comment:3 by Maxim Dounin, 3 years ago

That's because you've set "Sensitive" flag on the ticket in question. Should be accessible now.

Note: See TracTickets for help on using tickets.