Opened 4 months ago

Closed 4 months ago

#2375 closed defect (duplicate)

Дополнить документацию

Reported by: a.mironov.maksmart.ru@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.20.x
Keywords: Cc: a.mironov.maksmart.ru@…
uname -a: Linux fedora 5.15.45-xm1.0.fc34.x86_64 #1 SMP Tue Jun 7 07:09:25 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.20.1
built by gcc 11.2.1 20210728 (Red Hat 11.2.1-1) (GCC)
built with OpenSSL 1.1.1l FIPS 24 Aug 2021
TLS SNI support enabled
configure arguments: --prefix=/usr/share/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib64/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --http-client-body-temp-path=/var/lib/nginx/tmp/client_body --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-uwsgi-temp-path=/var/lib/nginx/tmp/uwsgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --pid-path=/run/nginx.pid --lock-path=/run/lock/subsys/nginx --user=nginx --group=nginx --with-compat --with-debug --with-file-aio --with-google_perftools_module --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_degradation_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_image_filter_module=dynamic --with-http_mp4_module --with-http_perl_module=dynamic --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-http_xslt_module=dynamic --with-mail=dynamic --with-mail_ssl_module --with-pcre --with-pcre-jit --with-stream=dynamic --with-stream_ssl_module --with-stream_ssl_preread_module --with-threads --with-cc-opt='-O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection' --with-ld-opt='-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-E'

Description

Добрый времени дня!

Объясните, пожалуйста, куда пропадают матчинги из location $1 и $2
P.S. с именованными матчингами такой проблемы не наблюдается.

Конфигурация:

    server {
      listen       127.0.0.1:80;

      location ~ ^/images/(\d+)x(\d+)/ {
        default_type text/plain;
        return 200 '$s3_image_url $1 $2 $3 $4';
      }
    }
    map $uri $s3_image_url {
      ~^(\/images)\/-\/(.*) $1/$2;
      ~^(\/images)\/\d+x\d+\/(.*) $1/$2;
    }

Проверка:

$ curl localhost/images/80x80/aaa/xxx
/images/aaa/xxx /images aaa/xxx  

Change History (1)

comment:1 by Maxim Dounin, 4 months ago

Resolution: duplicate
Status: newclosed

Duplicate of #1285.

Note: See TracTickets for help on using tickets.