Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#487 closed defect (invalid)

Connection problems after multiple reloads.

Reported by: frostbyte.pip.verisignlabs.com Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.5.x
Keywords: Cc:
uname -a: Linux ip-*-*-*-* 2.6.21.7-2.fc8xen #1 SMP Fri Feb 15 12:34:28 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.4.4
built by gcc 4.1.2 20080704 (Red Hat 4.1.2-54)
TLS SNI support disabled
configure arguments: --user=nginx --group=nginx --prefix=/usr/share/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --http-client-body-temp-path=/var/lib/nginx/tmp/client_body --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-uwsgi-temp-path=/var/lib/nginx/tmp/uwsgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --pid-path=/var/run/nginx.pid --lock-path=/var/lock/subsys/nginx --with-http_secure_link_module --with-http_random_index_module --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gzip_static_module --with-http_degradation_module --with-http_stub_status_module --with-http_perl_module --with-http_geoip_module --with-mail --with-mail_ssl_module --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic' --with-ipv6 --add-module=/home/*****/rpmbuild/BUILD/nginx-1.4.4/nginx-upload-progress-module --add-module=/home/*****/rpmbuild/BUILD/nginx-1.4.4/mod_zip-1.1.6 --add-module=/home/*****/rpmbuild/BUILD/nginx-1.4.4/ngx_http_auth_pam_module-1.2 --add-module=/home/*****/rpmbuild/BUILD/nginx-1.4.4/nginx-upload-module-2.2 --add-module=/home/*****/rpmbuild/BUILD/nginx-1.4.4/nginx-rtmp-module-master

Description

We are seeing failing inbound HTTP (non-SSL) connection attempts after some number of reload (kill -HUP) operations in the AWS EC2 environment. Concurrently the error log shows "worker process 8934 exited on signal 11" (crash with SIGSEGV).

The problem started after upgrading from 1.0.x to 1.4.4. Once the server goes into this state it remains there until another reload is executed.

This issue is similar to http://trac.nginx.org/nginx/ticket/390, except we are not using the try_files directive.

Change History (5)

comment:1 by Maxim Dounin, 6 years ago

Are you able to reproduce the problem without 3rd party modules compiled in? If yes, please follow instructions outlined at http://wiki.nginx.org/Debugging - in particular, please provide backtrace and full configuration. If no, you may try tracing problematic module and report the problem to it's author.

comment:2 by frostbyte.pip.verisignlabs.com, 6 years ago

Thanks, we are waiting for a core dump to get the stack trace. Unfortunately we can't remove the third-party modules since they are used in the application.

comment:3 by frostbyte.pip.verisignlabs.com, 6 years ago

Stack:

#0 0x000000000044b006 in ngx_http_script_flush_complex_value ()
#1 0x000000000044b509 in ngx_http_complex_value ()
#2 0x00000000004987f1 in ngx_http_upload_handler ()
#3 0x000000000043ba5c in ngx_http_core_content_phase ()
#4 0x00000000004367fd in ngx_http_core_run_phases ()
#5 0x0000000000440783 in ngx_http_process_request ()
#6 0x00000000004416e9 in ngx_http_process_request_line ()
#7 0x0000000000428f16 in ngx_event_process_posted ()
#8 0x000000000042ea4f in ngx_worker_process_cycle ()
#9 0x000000000042d1f0 in ngx_spawn_process ()
#10 0x000000000042e0ac in ngx_start_worker_processes ()
#11 0x000000000042f3c9 in ngx_master_process_cycle ()
#12 0x000000000041335d in main ()

Will investigate in upload module.

comment:4 by Maxim Dounin, 6 years ago

Resolution: invalid
Status: newclosed

Ok, closing this, looks like 3rd party module problem.

comment:5 by Maxim Dounin, 3 years ago

sensitive: 10
Note: See TracTickets for help on using tickets.