Opened 9 years ago

Closed 9 years ago

#58 closed defect (duplicate)

Worker process exists when using OPTIONS method from Delta-V (Subversion) via HTTPS

Reported by: www.google.com/accounts/o8/id?id=AItOawmTzOH08vlq5_MGz4PZj8RKN9A7EmIbd0g Owned by: somebody
Priority: major Milestone:
Component: nginx-core Version: 1.0.x
Keywords: https ssl svn subversion OPTIONS Cc:
uname -a: FreeBSD alfa.home 8.2-RELEASE-p3 FreeBSD 8.2-RELEASE-p3 #0: Tue Sep 27 18:45:57 UTC 2011 root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
nginx -V: nginx: nginx version: nginx/1.0.9
nginx: TLS SNI support enabled
nginx: configure arguments: --prefix=/usr/local/etc/nginx --with-cc-opt='-I /usr/local/include' --with-ld-opt='-L /usr/local/lib' --conf-path=/usr/local/etc/nginx/nginx.conf --sbin-path=/usr/local/sbin/nginx --pid-path=/var/run/nginx.pid --error-log-path=/var/log/nginx-error.log --user=www --group=www --with-file-aio --with-ipv6 --http-client-body-temp-path=/var/tmp/nginx/client_body_temp --http-fastcgi-temp-path=/var/tmp/nginx/fastcgi_temp --http-proxy-temp-path=/var/tmp/nginx/proxy_temp --http-scgi-temp-path=/var/tmp/nginx/scgi_temp --http-uwsgi-temp-path=/var/tmp/nginx/uwsgi_temp --http-log-path=/var/log/nginx-access.log --add-module=/usr/ports/www/nginx/work/giom-nginx_accept_language_module-02262ce --add-module=/usr/ports/www/nginx/work/ngx_http_auth_pam_module-1.2 --without-http-cache --with-http_gzip_static_module --with-http_mp4_module --with-http_ssl_module --with-http_stub_status_module --with-pcre

Description

I use Nginx as a frontend to Apache with module mod_dav_svn. Apache is responsible to handle Subversion via HTTP and Nginx is responsible for SSL encryption. However, since Nginx version 1.0.9 (bug exists also in 1.0.10) the worker process exits with signal 11 whenever I use Subversion client. Subversion client reports failure with SSL handshake when using OPTIONS method on repository url.
There is no error however, when I use browser, so with GET method.
There is no error if SSL is not used (Nginx is still used as reverse proxy).

Change History (3)

comment:1 by Maxim Dounin, 9 years ago

Status: newaccepted

Looks very similar to ticket #54. Please try the patch (or the workaround) from there. If it doesn't help, please provide more details (backtrace, config, etc - see http://wiki.nginx.org/Debugging).

comment:2 by www.google.com/accounts/o8/id?id=AItOawmTzOH08vlq5_MGz4PZj8RKN9A7EmIbd0g, 9 years ago

Thank you. The patch from ticket #54 solved the problem.

Note for FreeBSD users:
The patch should be renamed to "patch-src::http::ngx_http_request.c" and placed in "/usr/ports/www/nginx/files"

comment:3 by Maxim Dounin, 9 years ago

Resolution: duplicate
Status: acceptedclosed

Thanks for testing. Closing this as a duplicate of #54.

Note: See TracTickets for help on using tickets.